Меню Рубрики

Установка canon mf3010 в ubuntu linux

Помогатор Дмитрия Давыдова

То что я искал, но не мог найти. Это пригодится и вам.

пятница, 17 мая 2013 г.

Принтеры Canon в Linux

Работает без нареканий (как принтер так и сканер) в 32-разрядных Ubuntu. В 64-разрядных не испытывал. Нужны танцы с бубном.

Canon i-SENSYS LBP5050.
Мегаглючная вещь, с родными драйверами работать напрочь отказывается. Танцы с бубном обеспечены. Измучился с ним. Запустил его в итоге, но гадость редкостная: постоянно отваливается и не работают настройки яркости, контрастности и прочие. Принтер их просто игнорирует. Не советую покупать его к Linux’у.

Открываем терминал и пишем:

1. sudo apt-get install libusb-dev build-essential libsane-dev git-core
2. git clone git://git.debian.org/sane/sane-backends.git
3. cd sane-backends
4. ./configure —prefix=/usr —sysconfdir=/etc —localstatedir=/var && make && sudo make install

Вы установили систему сканирования, теперь вам надо подправить один файл, но сначала:

На что вы получите что-то такое:

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x 04a9 [Canon Inc], product=0x 2737 [MF4410]) at libusb:002:005
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend’s manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can’t be detected by this program.

# You may want to run this program as root to find all devices. Once you
# found the scanner devices, be sure to adjust access permissions as
# necessary.

Теперь собственно редактим файл:

6. sudo gedit /lib/udev/rules.d/40-libsane.rules

Добавляем туда вот такую строчку:

# Canon image > сюда пишем ваш принтер
ATTRS< >04a9 «, ATTRS< >2737 «, ENV=»yes»

Поняли откуда я взял >sane-find-scanner . У каждого устройства они разные.

Теперь сохраняем файл и перезагружаемся.

Если вы не знаете чем сканировать, то выполните в терминале sudo apt-get install xsane или установите xsane через центр приложений Ubuntu.

источник

Установка МФУ Canon MF3010 в Ubuntu

Запустить МФУ Canon MF3010 в Ubuntu дело не тривиальное, но возможное.

Настройка печати Canon MF3010

Названия пакетов могут отличаться в зависимости от разрядности Debian.

  • Подключаем принтер Canon MF3010, система распознает его и устанавливает необходимые дрова.
  • Настройка сканирования Canon MF3010

    Со сканером Canon MF3010 больше заморочек, но не настолько все печально, как с некоторыми моделями сканеров Canon, которые не идут под Ubuntu от слова «вообще».

      Установить XSane с приблудами:

    Для сканирования использовать программу XSane.

    Установка МФУ Canon MF3010 в Ubuntu : 9 комментариев

    Доброго времени суток, установил драйвера. Ubuntu 16.04 и Canon MF 3010. Сканер поднялся и сканирует. Принтер установился, но не печатает. Все задания уходят в никуда. Никаких ошибок, просто молча. Перерыл что мог, кто что сможет подсказать пож.

    Буквально вчера настраивал Canon MF3010 под Xubuntu. Первый пакет cndrvcups-common_2.70-1_amd64.deb встал стандартно через установщик. При установке второго пакета получил сообщение, что пакет уже установлен. Драйвера принтера не устанавливались.

    Пришлось установить второй пакет вручную:
    dpkg -i ./cndrvcups-ufr2-uk_2.70-1_amd64.deb

    Попробуйте удалить принтер и установить заново вручную. При установке система предлагает два принтера. Нужно выбрать USB.

    Да, так и делал. Пробовал на двух машинах Xubuntu 16.04 драйвера 3.20 с родного сайта Canon. МФУ заведомо живой — пробовал под виндой. Система печати CUPS рабочая. Поставил другой сетевой принтер — все отработало. Просмотрщик заданий пишет, что все задания выполнены. Файлы из спулера не уходят. Печати нет.

    Очень важно драйвера ставить версии 2.7, по ссылке в статье. С другими версиями может не работать.

    с версией 2,7 также пробовал, результат тот же
    нашел вот такой нюанс http://webhamster.ru/mytetrashare/index/mtb0/1622
    в завтра попробую

    Попробуй экспортировать в PDF и потом печатать его, может даже несколько раз подрят, пока не увидишь как закрутится значек на дисплее принтера.

    Доброго времени суток!
    Пытаюсь установить сканер MF3010 на Ubuntu 14.04 и столкнулась уже на втором этапе с такой проблемой: на компьютере просто нет папки «sane-backends/tools/udev/ «. Файл libsane.rules нашелся по адресу lib/udev/rules.d/ и в папку /etc/udev/rules.d вставляться не хочет принципиально (ноль реакции на Ctrl+V, не активна комманда «вставить»). xSane стоит, но сканер не видит в упор, при этом установленный ранее через официальные кэноновские драйвера принтер работает нормально. Если кто-то что-то может подсказать (с линуксом недавно и пока очень сильно на «Вы»), буду рада любой помощи.

    Директория sane-backends появится после выполнения команды git, которую нужно запускать в терминале с правами root’a.

    источник

    Операционная система Ubuntu

    Блог о современной полнофункциональной операционной системе, основанной на ядре Linux

    18 апреля 2015

    Как подключить принтер Canon MF3010 к ОС Ubuntu?

    После установки операционной системы Ubuntu Studio, и настройки некоторых программ, появилась необходимость воспользоваться принтером. Распечатать документ не составило труда, сразу после подключения принтера Canon MF3010. Так получилось, возможно, потому, что в Ubuntu, по умолчанию, все необходимые драйверы уже присутствуют, о чём я и писал в статье «Как установить драйвер в Ubuntu?». Но вот, через некоторое время, вывести на печать нужный документ, так просто не получилось.

    При подключении принтера, система писала, что отсутствует драйвер. При поиске нужного драйвера, через программу настройки системы печати на локальном компьютере System-config-printer, в списке моделей производителя Canon, не было модели принтера Canon MF3010.

    При добавлении Canon, но использовании драйвера другой модели, система выдавала ошибку. Подходящий драйвер удалось скачать со страницы программного обеспечения официального сайта Canon.

    Обратите внимание, сайт автоматически определяет операционную систему на машине, в данном случае — «Linux». На изображении выше я раскрыл выпадающее сообщение опции «Drivers», где сказано, что для выбранной операционной системы драйвера нет и, возможно, он установлен в вашей ОС, или вы не нуждаетесь в драйвере. Вот тут-то мне и вспомнилась ситуация, когда я распечатывал документ ранее, без настройки принтера.

    Скачать драйвер для принтера Canon MF3010 под ОС Linux версии 2.90, можно на той же странице, раскрыв выпадающее меню рекомендованных загрузок.

    Распаковываем загруженный архив Linux_UFRII_PrinterDriver_V290_us_EN.tar.gz в отдельный каталог, выбираем папку 32-bit или 64-bit системы. В каталоге «Debian» щёлкаем на deb-пакете «cndrvcups-common_2.90-1_amd64.deb», после чего, он должен открыться в Центре приложений Ubuntu. Установка данного пакета не исправила ситуации и принтер не работал. После установки второго пакета «cndrvcups-ufr2-us_2.90-1_amd64.deb» из папки «Debian», в программе настройки печати появилось новое устройство — «Canon MF3010 CNUSB#1» с соответствующим URI.

    По окончанию настройки печати, программа предложит распечатать пробную страницу. На вкладке параметров отображены свойства принтера.

    источник

    Настраиваем принтер Canon LBP3010 в Ubuntu 10.10


    Я почти полтора месяца пытался заставить работать этот принтер (за это время я даже успел перейти на сборку PinguyOS, обзор которой, возможно, скоро будет). И никаких успехов я не достиг в этом, но лишь до сегодняшнего дня. Пару дней назад я стал искать свежие мануалы по настройке этого принтера и сопоставив их, мне удалось сделать задуманное.
    И теперь я хочу поделиться работающим решением с хабрасообществом. Я надеюсь, что эта информация окажется полезна.

    Перед выполнением всех пунктов инструкции принтер лучше держать в выключенном состоянии.

    Итак, первым пунктом я предлагаю воспользоваться скриптом по автоматической настройке (что, правда, у меня не заработало, однако это наиболее простой метод установить сами драйвера) принтера, который можно скачать тут.

    Далее, распаковываем архив и запускаем имеющийся скрипт (вы должны находиться в терминале в той папке, в которой и лежит интересующий нас скрипт — canonLBP_install.sh) следующей командой (в терминале):
    sudo ./canonLBP_install.sh LBP3010

    Это установить все необходимые драйвера, а также некоторые дополнительные пакеты из числа зависимостей — очень удобно.
    Далее идём в Система — Администрирование — Печать и удаляем там появившийся принтер, он нам больше не понадобится.
    После этого запустим ещё одну команду в терминале:

    sudo /usr/sbin/lpadmin -p LBP3010 -m CNCUPSLBP3050CAPTK.ppd -v ccp:/var/ccpd/fifo0

    Это создаст новый принтер на основе pdd-файла, в котором, как я понял, описывается принцип работы с нашим LBP3010 (и, как видно из названия, с LBP3050). В результате этого действия в Система — Администрирование — Печать появится принтер с называнием LBP3010.

    Теперь нам надо привязать этот принтер к usb. Для этого выполняем следующую команду в терминале:

    sudo /usr/sbin/ccpdadmin -p LBP3010 -o /dev/usb/lp0

    После этого в консоли должно быть написано нечто следующее:

    CUPS_ConfigPath = /etc/cups/
    LOG Path = None
    UI Port = 59787

    Entry Num : Spooler : Backend : FIFO path : Device Path : Status
    —————————————————————————-
    [0] : LBP3010 : ccp : /var/ccpd/fifo0 : /dev/usb/lp0 : New!!

    Всё, что осталось сделать — подправить скрипт ccpd, который является важным звеном в работе принтера. В очередной раз возвращаемся к терминалу:

    Этой командой мы открываем этот скрипт в дефолтном текстовом редакторе под root’ом. Удаляем из этого файла всё, что вы там видите и вставляем новый скрипт:

    # startup script for Canon Printer Daemon for CUPS (ccpd)

    ### BEGIN INIT INFO
    # Provides: ccpd
    # Required-Start: $local_fs $remote_fs $syslog $network $named
    # Should-Start: $ALL
    # Required-Stop: $syslog $remote_fs
    # Default-Start: 2 3
    # Default-Stop: 0 1 4 5 6
    # Description: Start Canon Printer Daemon for CUPS
    ### END INIT INFO

    DAEMON=/usr/sbin/ccpd
    LOCKFILE=/var/lock/subsys/ccpd
    PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    NAME=ccpd
    DESC=»Canon Printer Daemon for CUPS»

    case $1 in
    start)
    log_begin_msg «Starting $DESC: $NAME»
    start-stop-daemon —start —quiet —exec $DAEMON
    log_end_msg $?
    ;;
    stop)
    log_begin_msg «Stopping $DESC: $NAME»
    start-stop-daemon —stop —quiet —oknodo —exec $DAEMON
    log_end_msg $?
    ;;
    status)
    echo «$DESC: $NAME:» `pidof $NAME`
    ;;
    restart)
    log_begin_msg «Restarting $DESC: $NAME»
    start-stop-daemon —stop —quiet —oknodo —exec $DAEMON
    sleep 1
    start-stop-daemon —start —quiet —exec $DAEMON
    log_end_msg $?
    ;;
    *)
    echo «Usage: ccpd »
    exit 1
    ;;
    esac

    Читайте также:  Установка кондиционера под балконом

    Затем перезапускаем сервис принтера опять же из терминала:

    sudo /etc/init.d/ccpd restart

    В ответ в консоли вы должны увидеть:

    * Restarting Canon Printer Daemon for CUPS: ccpd [ OK ]

    Для того, чтобы принтер работал и после перезапуска системы, выполняем ещё одну команду:

    sudo update-rc.d ccpd defaults 50

    И вы должны получить в ответ следующее:

    update-rc.d: warning: ccpd start runlevel arguments (2 3 4 5) do not match LSB Default-Start values (2 3)
    update-rc.d: warning: ccpd stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (0 1 4 5 6)
    Adding system startup for /etc/init.d/ccpd .
    /etc/rc0.d/K50ccpd -> ../init.d/ccpd
    /etc/rc1.d/K50ccpd -> ../init.d/ccpd
    /etc/rc6.d/K50ccpd -> ../init.d/ccpd
    /etc/rc2.d/S50ccpd -> ../init.d/ccpd
    /etc/rc3.d/S50ccpd -> ../init.d/ccpd
    /etc/rc4.d/S50ccpd -> ../init.d/ccpd
    /etc/rc5.d/S50ccpd -> ../init.d/ccpd

    Теперь можем включить принтер (я уверен, вы ждали этого момента 😉 )
    В системе появится ещё один принтер под названием Canon LBP3010/LBP3018/LBP3050, который система выставит как принтер по умолчанию, что нам совершенно не надо.
    Надо указать системе, чтобы она использовала по умолчанию принтер который мы с вами создали — то есть LBP3010, а этот новый принтер лично я оставил, на всякий случай. Если удалите и у вас всё будет работать — прошу отписаться в комментах.

    В свойствах этого принтера на вкладке Политика ставим галочки напротив приём заданий, разрешён и общий доступ.

    источник

    Canon MF3010

    Adobe, Acrobat, Acrobat Reader, PostScript и PostScript 3 являются товарными знаками
    Adobe Systems Incorporated.
    Linux является зарегистрированной торговой маркой Линуса Торвальдса.
    OpenOffice.org и логотип OpenOffice.org являются товарными знаками или зарегистрированными
    товарными знаками компании Oracle и / или ее филиалов.
    HP-GL является торговой маркой компании Hewlett-Packard.
    UNIX является товарным знаком The Open Group в США и других странах.
    Другие названия продуктов и компаний могут являться товарными знаками соответствующих
    владельцев.
    ————————————————— ——————————

    Перед началом работы
    1. Введение
    2. Распределение файлов Структура Canon UFR II Драйвер принтера для Linux
    3. Требования к аппаратному обеспечению
    4. Предупреждения, ограничения и ограничения
    ————————————————— ——————————

    1. Введение ————————————————- —————-
    Спасибо вам за помощью Canon UFR II / UFR II LT Printer Driver для Linux. Это
    Драйвер принтера предоставляет функции печати для Canon LBP / IMAGERUNNER ADVANCE /
    Цвет IMAGERUNNER / IMAGERUNNER / IMAGEPRESS / MF серию продуктов, работающих под
    CUPS (Common Unix Printing System) среды, системы печати, что функции
    на Linux операционных систем.

    2. Распределение файлов Структура Canon UFR II Драйвер принтера для Linux —-
    Canon UFR II Printer Driver для файлов дистрибутива заключаются в следующем:
    Кроме того, имя файла для CUPS драйверы общий модуль и драйвер принтера
    Модуль отличается в зависимости от версии.

    — README-ufr2-2.5xUS.txt (этот документ)
    Описывает дополнительную информацию о Canon UFR II Драйвер принтера для
    Linux.

    — Лицензия-ufr2drv-2.5x.txt
    Описывает Лицензионное соглашение на Canon UFR II Драйвер принтера для Linux.

    — Гид-ufr2-2.5xUS.tar.gz
    Онлайн руководство, которое объясняет, как использовать Canon UFR II Printer Driver для
    Linux.
    Это включает в себя требования к системе, установке и использовании Canon UFR
    II Драйвер принтера для Linux.
    Поскольку этот файл в сжатом формате, необходимо извлечь его
    соответствующий каталог перед чтением.

    — Cndrvcups-общий-2.50-X.i386.rpm (для 32-разрядной)
    — Cndrvcups-общий-2.50-X.x86_64.rpm (для 64-разрядной)
    — Cndrvcups-common_2.50-X_i386.deb (для Debian 32-бит)
    Инсталляционный пакет для CUPS драйверы общий модуль используется Canon UFR II
    Драйвер принтера для Linux.

    — Cndrvcups-ufr2-нас-2.50-X.i386.rpm (для 32-разрядной)
    — Cndrvcups-ufr2-нас-2.50-X.x86_64.rpm (для 64-разрядной)
    — Cndrvcups-ufr2-us_2.50-X_i386.deb (для Debian 32-бит)
    Инсталляционный пакет для Canon UFR II Printer Driver для Linux.

    — Cndrvcups-общий-2.50-X.tar.gz
    Исходный файл для CUPS драйверы общий модуль используется принтер Canon UFR II
    Драйвер для Linux.

    — Cndrvcups-фунт-2.50-X.tar.gz
    Исходный файл для Canon UFR II Printer Driver для Linux.

    3. Требования к аппаратному обеспечению ———————————————— ——-
    Этот драйвер принтера может быть использован со следующей аппаратной среды.

    Оборудование:
    Компьютер, который позволяет управлять Linux, с x86-совместимый процессор (32-разрядная или
    64-разрядная)

    — Поддержка принтеров
    Canon UFR II Printer Driver для Linux поддерживает следующие продукты Canon.
    См. следующий список, чтобы найти файл PPD-коммуникационной среды
    соответствующий принтер, который вы используете.
    * Моделей принтеров с «A» и «*» после их имена в «BIDI (би-
    Направленный) «колонки требуют двунаправленного соединения печати. ​​моделей принтеров
    с «A *» использовать однонаправленную печать при подключении через USB.
    * Моделей принтеров с «A» после их имена в «IPv6» IPv6 колонке поддержку.

    Canon LBP6650/3470 UFR II (CNCUPSLBP6650ZS.ppd)
    LBP3470 (BIDI: -, IPv6:)

    Canon LBP6670 UFR II (CNCUPSLBP6670ZS.ppd)
    LBP6670dn (BIDI: -, IPv6:)

    Canon LBP7660C UFR II (CNCUPSLBP7660CZS.ppd)
    LBP7660Cdn (BIDI: -, IPv6:)

    Canon iR1018/1022/1023 UFRII LT (CNCUPSIR1023ZS.ppd)
    IMAGERUNNER 1023 (BIDI: -, IPv6: -)

    Canon iR1020/1024/1025 UFRII LT (CNCUPSIR1025ZS.ppd)
    IMAGERUNNER 1025/1025iF/1025N (BIDI: -, IPv6: -)

    Canon iR1730/1740/1750 UFRII LT (CNCUPSIR1750ZS.ppd)
    IMAGERUNNER 1730/1740/1750 (BIDI: -, IPv6: -)

    Canon iR2016 UFRII LT (CNCUPSIR2016ZS.ppd)
    IMAGERUNNER 2016 (BIDI: -, IPv6: -)

    Canon iR2018 UFRII LT (CNCUPSIR2018ZS.ppd)
    IMAGERUNNER 2018 (BIDI: -, IPv6: -)

    Canon iR2020 UFRII LT (CNCUPSIR2020ZS.ppd)
    IMAGERUNNER 2020 (BIDI: -, IPv6: -)

    Canon iR2022/2025/2030 UFRII LT (CNCUPSIR2030ZS.ppd)
    IMAGERUNNER 2022 года, IMAGERUNNER 2025 года, IMAGERUNNER 2030 (BIDI: -, IPv6: -)

    Canon iR2318/2320 UFRII LT (CNCUPSIR2320ZS.ppd)
    IMAGERUNNER 2320L (BIDI: -, IPv6: -)

    Canon iR2420 UFRII LT (CNCUPSIR2420ZS.ppd)
    imageRUNNER2420 (BIDI: -, IPv6: -)

    Canon iR2422 UFRII LT (CNCUPSIR2422ZS.ppd)
    imageRUNNER2422 (BIDI: -, IPv6: -)

    CANON IR 2520 UFRII LT (CNCUPSIR2520ZS.ppd)
    imageRUNNER2520 (BIDI: -, IPv6: -)

    CANON IR 2525/2530 UFRII LT (CNCUPSIR2530ZS.ppd)
    imageRUNNER2525/2530 (BIDI: -, IPv6: -)

    CANON IR 2535/2545 UFRII LT (CNCUPSIR2545ZS.ppd)
    imageRUNNER2535/2535i/2545/2545i (BIDI: -, IPv6: -)

    Canon iRC1021/1022 UFRII LT (CNCUPSIRC1022ZS.ppd)
    Цвет IMAGERUNNER C1022/C1022i (BIDI: -, IPv6: -)

    Canon iRC1028/1030 UFRII LT (CNCUPSIRC1030ZS.ppd)
    Цвет IMAGERUNNER C1028/C1030 (BIDI: A, IPv6: -)

    Canon L90/L160/L230 UFRII LT (CNCUPSL230ZS.ppd)
    L90 (BIDI: -, IPv6: -)

    Canon L100/L150/L170 UFRII LT (CNCUPSL170ZS.ppd)
    L100 (BIDI: -, IPv6: -)

    Canon LC800/L3000 UFRII LT (CNCUPSLC3000ZS.ppd)
    LC800 Series (BIDI: -, IPv6: -)

    Canon D400-450 (CNCUPSD450ZS.ppd)
    D400-450 (BIDI: -, IPv6: -)

    Canon D460-490 (CNCUPSD490ZS.ppd)
    D460-490 (BIDI: -, IPv6: -)

    Canon D500 серии UFRII LT (CNCUPSD500ZS.ppd)
    D500 Series (BIDI: -, IPv6: -)

    Canon D1100/MF6600 UFRII LT (CNCUPSD1100ZS.ppd)
    D1100 Series (BIDI: -, IPv6: -)

    Canon D1300/MF6700 UFRII LT (CNCUPSD1300ZS.ppd)
    D1300 Series (BIDI: -, IPv6:)

    Canon MF3010 (CNCUPSMF3010ZS.ppd)
    MF3010 (BIDI: -, IPv6: -)

    Canon MF4100 серии UFRII LT (CNCUPSMF4100ZS.ppd)
    MF4100 Series (BIDI: -, IPv6: -)

    Canon MF4200 серии UFRII LT (CNCUPSMF4200ZS.ppd)
    MF4200 Series (BIDI: -, IPv6: -)

    Canon MF4320-4350 (CNCUPSMF4350ZS.ppd)
    MF4320-4350 (BIDI: -, IPv6: -)

    Canon MF4360-4390 (CNCUPSMF4390ZS.ppd)
    MF4360-4390 (BIDI: -, IPv6: -)

    Canon MF4400 UFRII LT (CNCUPSMF4400ZS.ppd)
    MF4400 Series (BIDI: -, IPv6: -)

    Canon MF4500 UFRII LT (CNCUPSMF4500ZS.ppd)
    MF4500 Series (BIDI: -, IPv6: -)

    Canon MF4500w Series (CNCUPSMF4500WZS.ppd)
    MF4500w (BIDI: -, IPv6: -)

    Canon MF4600 серии UFRII LT (CNCUPSMF4600ZS.ppd)
    MF4600 Series (BIDI: -, IPv6: -)

    Canon MF5800 серии UFRII LT (CNCUPSMF5800ZS.ppd)
    MF5800 Series (BIDI: -, IPv6: -)

    Canon MF5900 серии UFRII LT (CNCUPSMF5900ZS.ppd)
    MF5900 Series (BIDI: -, IPv6:)

    Canon MF6500 серии UFRII LT (CNCUPSMF6500ZS.ppd)
    MF6500 Series (BIDI: -, IPv6: -)

    Canon MF7200 серии UFRII LT (CNCUPSMF7200ZS.ppd)
    MF7200 Series (BIDI: -, IPv6: -)

    Canon MF7400 серии UFRII LT (CNCUPSMF7400ZS.ppd)
    MF7400 Series (BIDI: -, IPv6: -)

    Canon MF8000 серии UFRII LT (CNCUPSMF8000ZS.ppd)
    MF8000 Series (BIDI: A, IPv6:)

    Canon MF8000C UFRII серии LT (CNCUPSMF8000CZS.ppd)
    MF8000C (BIDI: A, IPv6:)

    Canon MF8300 серии UFRII LT (CNCUPSMF8300ZS.ppd)
    MF8300 Series (BIDI: A, IPv6:)

    Canon MF8300C UFRII серии LT (CNCUPSMF8300CZS.ppd)
    MF8300C (BIDI: A, IPv6:)

    Canon MF8400 UFRII LT (CNCUPSMF8400ZS.ppd)
    MF8400 Series (BIDI: A, IPv6: -)

    Canon MF9100/9300 UFRII LT (CNCUPSMF9300ZS.ppd)
    MF9100 Series (BIDI: A, IPv6: -)

    Canon MF9200 серии UFRII LT (CNCUPSMF9200ZS.ppd)
    MF9200 Series (BIDI: A, IPv6: -)

    Пожалуйста, обратитесь к онлайн-руководство по установке метод и конкретное использование.

    — Если вы установили «cndrvcups-общий» пакет версии 2.50, убедитесь, что вы устанавливаете
    та же версия «cndrvcups-ufr2» пакета, то есть 2,50.

    — Обновление установки не доступны при обновлении до версии 1.40 или более поздней версии,
    как имена файлов, которые не согласуются с более старыми версиями. Если у вас есть
    старая версия на вашем компьютере, вы должны удалить старый драйвер, то
    установить новый драйвер.

    — Если более чем два драйвера устанавливаются с помощью LIPSLX, UFRII (США), и UFRII
    (UK) установки драйверов пакетов, и только один из этих драйверов обновляется,
    произойдет ошибка.
    Эта проблема может быть решена путем обновления всех установленных драйверов вместе.

    — При указании нескольких страниц / копий [Page Layout] в [General] лист
    Для печати документа, созданного с StarSuite7/OpenOffice, в связи с причиной
    операции с помощью модуля CUPS, настройки не корректно назначен на
    несколько страниц и выход.

    — PostScript файлы, созданные в количестве экземпляров, указанном в OpenOffice.org
    или StarSuite страдают не по значению, указанному в [Число копий] в
    [cngplp] диалогового окна (водитель UI), а количество копий устанавливается при
    создание PostScript файл.

    — Если изменения настроек в драйвере интерфейса, во время обработки печати,
    напечатанный результат будет отражать изменения настроек.

    — Если [Яркость и гамма] указано в [General] лист из
    приложения, такие как OpenOffice.org, GIMP, или Acrobat Reader v.5.0,
    Настройки будут недействительны.

    Читайте также:  Установка предохранителей в нулевом рабочем проводе

    — Вы не можете печатать PDF документ непосредственно указав его с рабочего стола или
    командной строки. При печати PDF-документ, он рекомендуется распечатать
    от Acrobat Reader или Adobe Reader.

    — Максимальное число файлов, которые могут быть проведены в очереди на печать при печати
    составляет 500 в соответствии с CUPS спецификаций. Файлы в очереди после 500-файла
    будут игнорироваться.

    — Если вы используете SUSE LINUX Professional 9.3, драйвер интерфейса может отображать
    непонятными символами. Вы можете решить эту проблему с помощью следующих
    метод.
    1) Войдите в систему как «корень».
    2) Выполните следующую команду, чтобы изменить параметры среды GTK +.
    # Кд / и т.д. /
    # В-х годов опция / GNOME / GTK /.

    — Если вы используете SUSE LINUX Professional 9.3, предупреждение может возникнуть при
    активировать драйвер интерфейса. Вы можете решить эту проблему с помощью следующих методов.
    1) Открыть [K Menu] -> [Control Center].
    2) Выберите [Внешний вид и темы].
    3) Выберите [цвета].
    4) Снимите флажок [Применить цветов к не-KDE приложения].
    5) Закрыть [Control Center].

    — При печати из OpenOffice.org, некоторые отделочные функций, таких как [Повернуть]
    может работать неправильно, если вы укажете несколько копий для [Кол-во
    копий] в драйвере интерфейса.

    — Если вы используете SUSE Linux 9.3 или SUSE Linux 10.0, а также печати с
    [Печать] диалогового окна Mozilla FireFox или, так как несколько копий установка
    не включен, вы можете напечатать только один экземпляр, независимо от того, сколько копий
    указали. Эта проблема может быть решена путем изменения следующие строки в
    Файл «/ и т.д. / чашки / mime.convs».
    [Перед изменить]
    Приложение / Mozilla пс приложение / PostScript 33 pswrite
    [После изменения]
    Приложение / Mozilla пс приложение / PostScript 33 pstops

    — При выполнении печать баннеров в Fedora 8/9, если задать другое значение,
    чем [нет] для [End] под [заголовок] на листе [General], очереди печати
    остановится.

    — Если вы попытаетесь печатать из цветов IMAGERUNNER / LBP принтере, используя этот драйвер
    В 64-битной версии Fedora 9/10/11/12/13/14/15/16 системы окружающей среды,
    Результаты печати не может быть удовлетворительным.
    Это потому, что когда 64-разрядные пакеты установлены на стандартные
    Способ установки, 32-разрядные JPEG библиотека не установлена.
    Эта проблема может быть решена путем установки пакета в качестве дополнительного
    установки.
    Выполните следующую команду.
    # ням установить libjpeg.i386
    # ням установить libjpeg.i586
    # ням установить libjpeg.i686
    # ням установить libjpeg-turbo.i686

    — Чтобы установить общий модуль в 64-битной версии Fedora 10/11/12/13/14 /
    15/16, вам нужен 32-разрядной версии Glibc библиотеки.
    Вы можете установить Glibc библиотеки, выполнив следующую команду:
    # ням установить glibc.i386
    # ням установить glibc.i586
    # ням установить glibc.i686
    Кроме того, драйверы принтера с версии 1.90 вперед требует 32-разрядная версия
    xml2 библиотеки.
    Вы можете включить печать, выполнив следующую команду:
    # ням установить libxml2.i386
    # ням установить libxml2.i586
    # ням установить libxml2.i686

    — Если вы используете Fedora 11 и печати с очередью печати остановлена ​​после
    Отмена задания, работа приостановлена. В этом случае, нажмите кнопку [Maintenance]
    Кнопка в Принтеры в интерфейсе CUPSWeb и выберите [Продолжить принтера], чтобы
    выполните [на рассмотрении с] задание еще раз.
    Если вы не можете найти кнопке [Обслуживание], Вы можете выбрать [Resume Printer]
    выбрав [Pause принтера].

    — Если вы используете OpenSUSE 10.2 или SLED10SP1, которая включает в себя Ghostscript
    Версия 8.15.3, вы не сможете распечатать некоторые документы. Для решения этой
    Проблема, установить другую версию Ghostscript.

    — Если вы используете OpenSUSE 11.0 с Ghostscript версии 8.6.x, печать с
    Evince, GIMP, или других приложений может занять некоторое время.

    — Хотя Okular является стандартным для просмотра документов в OpenSUSE 11.1 KDE
    окружающей среды, функции драйвера принтера не работают правильно с ним.
    Вы можете решить эту проблему с помощью других приложений, таких как Acrobat Reader
    и т.д.

    — Если вы используете Ubuntu или Debian 7.04/7.10/8.04/8.10/9.04 3.1/4.0/5.0,
    libcupsys2 библиотеки, необходимые для установки общих модулей.
    Вы можете установить libcupsys2 библиотеки, выполнив следующую команду.
    # APT-получить установку libcupsys2

    — Если вы используете Ubuntu 8.10/9.04/9.10/10.04/10.10/11.04/11.10, принтер
    будет печататься с этим методом вывода бумаги по умолчанию, независимо от того,
    , указанный метод вывода бумаги.
    Эта проблема может быть решена путем изменения метода вывода бумаги для печати из
    CUPS настройки принтера (Web).

    — Если вы используете Ubuntu 8.10, с указанием обратного заказ на печать не
    влияет на результат печати.
    Эта проблема может быть решена путем обновления CUPS.

    — Если вы используете Ubuntu 8.10/9.04/9.10/10.04/10.10/11.04/11.10, при печати
    PDF данные или данные PS, яркости и настройки гамма-коррекции не может быть
    отражение в печати результатов.

    — Если вы используете Adobe Reader 7.0.x, а также изменять такие параметры, как размер бумаги,
    Источник бумаги, двусторонняя печать, и т.д. В диалоговом окне печати, эти параметры
    автоматически добавляются к принтеру команды. Тем не менее, эти параметры будут
    Не работает, потому что они не могут быть признаны в качестве параметров командной строки. Для решения этой
    Проблема, используйте «-о», чтобы отделить каждую команду вариантов.
    [До]-о InputSlot = Manual, Duplex = DuplexNotumble
    [После]-о InputSlot = ручной дуплекс-O = DuplexNoTumble

    — При печати PDF-файлов с помощью Adobe Reader 8, могут быть случаи, когда
    некоторые данные изображения не печатаются.
    Эта проблема может быть решена путем печати с помощью Adobe Reader 7 или Adobe Reader 9,
    или установка 3-го уровня в PostScript вариантов.

    — При выполнении 2-сторонняя печать с Adobe Reader 8.1.2, если вы укажете [ON
    (Short краями Binding)] для [Дуплекс] Печать в печатных свойств для Adobe
    Reader 8.1.2, документ будет печататься на обеих сторонах с длинными краями
    привязки.
    Эта проблема может быть решена путем печати документа с помощью драйвера принтера
    Пользовательского интерфейса.

    — Если вы используете Vine Linux 3.1, вы можете взять время, чтобы печатать из Adobe Reader
    7.0.9 быть или не быть в состоянии напечатать некоторые документы.

    — При печати PDF-файлов, содержащих японские иероглифы из командной строки
    В Vine Linux 4.1, могут быть случаи, когда Ghostscript завершает
    Неожиданно, в результате чего печати остановить.
    Эта проблема может быть решена путем печати PDF-файлов с помощью Adobe Reader.

    — При печати PDF-файлов из Adobe Reader 8 в Vine Linux 4.1, могут быть
    случаях, когда Ghostscript завершает неожиданно, в результате чего очереди печати
    остановить.
    Это вызвано Ghostscript (7.07) не в состоянии проанализировать PS файлов
    создан Adobe Reader 8 и, следовательно, прекращение преждевременно, тем самым,
    остановки процесса фильтрации.
    Эта проблема может быть решена с помощью Adobe Reader 7.

    — При печати текстовых файлов в альбомной ориентации в Vine Linux 4.1/4.2,
    Fedora 8/9, или Red Hat Enterprise Linux v.5, могут быть случаи, когда
    Текстовый файл печатается в портретной ориентации с некоторыми из печати данных не
    печатается на странице.
    Это вызвано CUPS фильтра, работающих в дистрибутив вы используете
    создание команды PS, который уже установлен на портрете.
    Кроме того, некоторые функции, предусмотренные в CUPS стандартный фильтр «texttops»
    Не может работать неправильно.
    Эта проблема может быть решена путем изменения имени CUPS фильтра, указанным в
    «Текст / равнина» строка ввода в CUPS установки файла «mime.convs» в CUPS
    стандартный фильтр «texttops». Это приведет японские символы бытия
    опечатка, поэтому при печати символов японского языка, необходимо, чтобы
    напечатать команду PS создан с помощью текстового редактора или текстового / PostScript преобразования
    программы, такие как каши.

    — Если задать параметры Paper Source в диалоговом окне печати из приложений
    таких как Writer OpenOffice.org, настройки, сделанные с применением являются
    переопределить параметры принтера драйвер интерфейса. Для печати с нужной бумагой
    Источник, указать источник бумаги из пользовательского интерфейса драйвера принтера заранее,
    или распечатать из командной строки.

    — Если вы используете Debian GNU / Linux 4.0, ошибка PPD файла может возникнуть при
    Зарегистрируйтесь принтера (PPD) с диспетчера очереди печати. Чтобы решить эту проблему, используйте
    «-P (полный путь к PPD)» вместо «-м» при указании PPD помощью
    командной строки.
    Пример: / USR / sbin / lpadmin-р iR2016
    -P / usr/share/cups/model/CNCUPSIR2016ZS.ppd
    LPD-V :/ / 192.168.1.10/iR2016-E

    — В Ubuntu 10.10/11.04/11.10, Fedora 14/15/16, при регистрации принтера,
    Размер по умолчанию не может быть размер документа, который соответствует языку /
    области операционной системы. Вы можете преодолеть эту проблему регистрации
    Принтер по следующим способом.
    [Способ 1]
    Укажите «-P» вместо «м» на имя PPD файла в меню «lpadmin»
    команды.
    Если указать «-P» для файла PPD, указать полное имя пути или
    относительный путь для указанного файла PPD.
    Пример)
    # / USR / sbin / lpadmin-р [имя принтера для регистрации]-P [PPD путь к файлу]-V
    LPD: [Устройство URI]-E
    [Способ 2]
    1) Включить «DefaultPaperSize Auto» в «/ и т.д. / чашки / cupsd.conf», а затем перезапустить CUPS.
    2) Регистрация принтера.

    — Если вы используете Debian GNU / Linux 4.0, вы можете взять время, чтобы печатать с Evince
    быть или не быть в состоянии напечатать некоторые документы. Чтобы решить эту проблему, напечатайте
    документ из другого приложения.

    — Если вы используете Debian GNU / Linux 4.0 r6, и при попытке напечатать текстовый файл
    с помощью пользовательского интерфейса драйвера принтера при EUC-JP установлен в качестве языка, печать
    провал.
    Эта проблема может быть решена путем печати команде PS создан с помощью текстового редактора
    или текст / Postscript преобразования программы, такие как каши.

    — Если вы используете Debian GNU / Linux 5.0.2, GS-ESP модуля требуется
    установить общий модуль.
    Вы можете установить GS-ESP модуль, выполнив следующую команду.
    # APT-получить установку GS-ESP

    — В зависимости от дистрибутива, который вы используете, когда вы регистрируетесь на принтер USB
    с указанием диспетчера очереди печати / Dev / USB / LP * как [Device URI], печать
    завершится с ошибкой «Принтер не подключен» отображаются. Чтобы решить эту проблему,
    указать конкретное имя принтера как [Device URI], которая отображается с помощью
    Следующие команды.
    Пример) Если вы используете MF4600 серии
    1) Отображение [Device URI]
    # / USR / sbin / lpinfo-V
    Прямое USB :/ / Canon/MF4600% 20Series% 20 (FAX)
    Прямое USB :/ / Canon/MF4600% 20Series% 20 (PCL5e)
    Прямое USB :/ / Canon/MF4600% 20Series% 20 (PCL6)
    Прямое USB :/ / Canon/MF4600% 20Series% 20 (UFRII% 20lt)
    2) Регистрация принтера
    # Lpadmin-р MF4600_USB-м CNCUPSMF4600ZS.ppd
    -V USB :/ / Canon/MF4600% 20Series% 20 (UFRII% 20lt)-E

    Читайте также:  Установка винилового проигрывателя на шипы

    — При печати PDF-файлов из Adobe Reader в Mandriva, независимо от
    Версия используются, могут быть случаи, когда Ghostscript завершает
    Неожиданно, в результате чего очереди печати остановить.
    Это вызвано Ghostscript (8.60) не в состоянии проанализировать PS команд
    созданные с помощью PS файлов, для которых параметры безопасности были указаны, и
    следовательно, прекращение преждевременно, тем самым останавливая процесс фильтрации.
    Эту проблему можно избежать, если не печатать PDF файлы, которые имеют безопасность
    настройки с помощью Adobe Reader.

    — Если вы используете Mandriva One 2008 Spring и Mandriva 2008 PowerPack с CUPS
    Версия 1.3.6, непредвиденные результаты печати могут возникнуть даже при печати с
    стандартные функции печати CUPS.
    Эта проблема может быть решена путем обновления CUPS.

    — Если ваша версия Ghostscript является 8.6.x, вы не можете быть в состоянии напечатать несколько
    документов.

    — Там могут быть случаи, когда MF4270, или L90/L160/L230 принтеры, в зависимости от
    окружающей среды и тип данных для печати, не может печатать в связи с принтером данных
    Ошибка в устройстве конца.
    Это вызвано тайм-аут ошибка, возникающая при устройстве конца.
    Эта проблема может быть решена путем включения ошибка тайм-аут отправиться на
    устройства.

    — Если Q3 финишер или финишер Q4 прилагается и указать A4,
    Письмо, или как юридические, размер страницы, в документе не печатается правильно, если
    Вы пытаетесь печатать с [Привязка Расположение] на [Короткий край (Top)] и
    [Позиция сшивания] на [Top (Double)] или [Привязка Расположение] установлен на
    [Короткий край (нижний)] и [Позиция сшивания] на [Bottom (Double)], в
    [Окончательная обработка] лист.

    — Если вы используете ИК C1021/C1021i, MF8400 Series, или MF9100 Series,
    хотя IPv6 может быть установлен с панели управления принтера, только IPv4
    поддерживает сетевые соединения.
    — Если вы используете CentOS 5.3, вы не можете распечатать число копий, как вы
    , указанный в Evince.
    Вы можете решить эту проблему путем печати PDF из других зрителей, таких как Adobe
    Читатель или с помощью следующих методов.
    1) Установить количество копий для 1 и выберите команду PS для выходных
    назначения в Evince для вывода в файл.
    2) Распечатать выход PS команды в виде файла после указания количества копий
    В cngplp.

    — Если вы используете Ubuntu 9.04 и обновить версию CUPS на «1.3.9-17ubuntu3.2
    », То печать не из-за некорректных данных PS.
    Вы можете избежать этой проблемы путем понижения версии CUPS
    «1.3.9-17ubuntu3.1».
    — Выполните следующую команду.
    # APT-получить установку чашки = 1.3.9-17ubuntu3.1

    — Если вы используете Ubuntu 9.04/9.10/10.04/10.10/11.04/11.10, Fedora 11/12/13/14 /
    15/16, и страниц печати баннеров, указанное количество баннеров страницы
    напечатаны.

    — В Fedora 15/16 и Ubuntu 11.04/11.10, если вы печатаете с яркостью
    указано от 0% до 9%, настройки яркости не применяется и
    документ напечатан так же, как если яркость была указана как 100%.

    — Если вы используете 32-разрядной или 64-разрядной версии Fedora 13/14/15/16 и печать
    TIFF или JPEG файлов из пользовательского интерфейса драйвера или командной строки, напечатанное изображение может
    быть разбиты. Эта проблема может быть решена путем вывода файла в качестве
    PostScript файл из приложения, такие как GIMP, то печать с
    командной строки, введя команду PostScript используется для вывода файлов после
    [Cngplp].

    — Если вы печатаете TIFF или JPEG изображений из пользовательского интерфейса драйвера или командной строки,
    Изображение может быть разделено и распечатать на нескольких страницах.
    Эта проблема может быть решена путем вывода изображения в виде PostScript файла с
    приложений, таких как GIMP, то печати PostScript файла с водителем
    Пользовательского интерфейса или командной строки.

    — Если вы используете Fedora 13/14/15/16, даже если вы укажете яркости и
    гамма-настройки пользовательского интерфейса драйвера или из командной строки, эти параметры не являются
    применяются к печатным результате начиная со второго страницу.
    Это связано с этими функциями не включена, поскольку Ghostscript не
    Правильно признать PostScript данные, созданные приложением.

    — Если вы измените метод вывода на [Print] после указания [Обеспеченные печати], а
    Метод вывода и нажав кнопку [Сохранить / Настройки печати] в драйвере интерфейса,
    Название документа вы выводите с помощью [Обеспеченные Печать] отображается в работу
    войти в принтере. Эта проблема может быть решена с помощью [Сохранить / Распечатать
    Настройки] вместо кнопки [Печать], чтобы распечатать при изменении
    Метод вывода из работы [Обеспеченные для печати] на [Печать].

    — После ввода значений или текстовых зрения, если вы закончите, нажав на [X]
    Кнопка в правом верхнем углу диалогового окна, значение рассматривается как действительный
    Значение так же, как при нажатии на кнопку [ОК]. Если вы хотите, чтобы
    отключить установленное значение, нажмите кнопку [Отмена].

    — Следующие символы трактуются по-разному в разных версиях CUPS,
    Поэтому мы рекомендуем вам не использовать их.
    «#»
    С CUPS версии 1.4 и далее, «#» рассматривается как комментарий, поэтому если Вы
    использовать его в командную строку, после символов «#» не признаются в качестве
    команды.
    «\»
    Если ввести «\ \ \ 123», команда признала следующим образом,
    В зависимости от версии CUPS:
    CUPS V1.1.22: \ 123
    CUPS v1.4.3: \ \ 123

    — В зависимости от версии GTK (GIMP Toolkit), некоторые символы могут быть
    непонятными, когда на экране отображается, но это не означает,
    Проблема с функциями и набором значений. Перерисовать соответствующее текстовое поле
    Для решения этой проблемы.

    — Если вы используете Fedora 12 и Ubuntu 9.10, когда вы изменить настройки по умолчанию
    из веб-интерфейса CUPS, значения по умолчанию будут сохранены, даже если есть
    Конфликт между настройками для каждой функции. Кроме того, после настройки
    сохраняется с конфликтом, вы не можете сохранить настройки снова, даже если вы используете
    Веб-интерфейс, чтобы изменить их правильные значения, где нет конфликтов.
    Если вы показываете [cngplp] диалоговое окно, в этой ситуации, недопустимую операцию
    может произойти.
    Вы можете использовать следующие методы для решения этой проблемы:
    [Способ 1] Fedora 12 (32-bit/64-bit) и Ubuntu 9.10
    Повторно регистрироваться на принтер, который выполнил недопустимую операцию.
    [Способ 2] Fedora 12 (32-bit/64-bit)
    Выполните следующую команду, чтобы обновить CUPS:
    # ням обновление cups.i686
    # ням обновление cups.x86_64

    — Если вы используете этот драйвер в 64-разрядной среде, а также обновлять версию
    2.00, 2.10, или 2,20 драйверов до версии 2.30 или более поздней версии, ошибки могут возникать при
    печать.
    Эта проблема может быть решена путем удаления (мин-E [водитель]), то повторно
    -Установка (мин-я [водитель]) новый драйвер.
    Кроме того, вы можете удалить старые драйвера (мин-E [водитель]) вместо
    его обновления, а затем установить новый драйвер (мин-я [водитель]).

    — Если указать название документа, что превышает 32 байт при печати,
    строку символов для названия документа будет удалена из 33-й байт вперед по
    водитель, и имя документа отображается в устройстве будет максимум
    32 байт.

    — Чтобы использовать этот драйвер принтера, необходимо Ghostscript в том числе общих API.
    Перед установкой драйвера убедитесь, что Ghostscript установлен. Вы можете
    сделать это с помощью следующей команды в терминале программы, такие как GNOME
    Терминал.
    % GS-ч | GREP opvp
    Если «opvp» и «oprp» отображаются в результате Ghostscript включая общие
    API-интерфейсы установлена. Если результата не отображается, вы можете получить от Ghostscript
    по следующему адресу:
    http://opfc.sourceforge.jp/index.html.en

    — Если вы используете Ubuntu 12.04 и попытке напечатать цветной ИК-порт или цвета LBP
    Серия принтеров использовании этого драйвера, вы не сможете печатать.
    Это потому, что библиотека JPEG используется этот драйвер не установлен, когда вы
    сделать стандартную установку в Ubuntu 12.04. Вы можете решить эту проблему,
    выполнение установки дополнительных пакетов.
    Выполните следующую команду:
    # APT-получить установку libjpeg62

    ================================================== ==============================
    Поддержка
    ================================================== ==============================
    Это программное обеспечение и связанной с ней информации независимо разработанной Canon и
    распространяется по вашей местной компанией Canon. Canon (как производитель принтеров
    поддержки этого программного обеспечения и сопутствующей информации) и ваши местные компании Canon
    (В качестве дистрибьютора), не будет отвечать на любые вопросы об этой программе или
    Дополнительная информация. Тем не менее, любые запросы об ремонт принтеров, расходных
    расходные материалы и устройства должны быть направлены на Вашем Canon местной компании.
    ================================================== ==============================
    Copyright CANON ИНК 2012

    наверное стоит сказать спасибо, но так как я новичек, найдя инструкцию по установке:
    file:///home/valeryus/%D0%94%D0%BE%D0%BA%D1%83%D0%BC%D0%B5%D0%BD%D1%82%D1%8B/guide-ufr2-2.5xUS/contents/main_02_01.html#11465849f21d2e6a07f85f995779215d
    впадаю в ступор.
    ввод первой команды в терминал — $ su
    выдает — command not found

    какой пакет устанавливать — rpm или deb? .

    vzvl, сделал как вы писали. подключил принтер. выдало сообщение о настройке принтера. затем сообщение об отсутствии драйвера принтера. на этом все.

    попробовал через центр управления-принтеры. ничего не получилось.

    calambus:
    Valeryus ,я не имею практики работы с такого типа оборудованием , но советую посмотреть в поиске , какая есть информация по этой теме в интернете :установка canon mf3010 в Ubuntu Linux

    calambus, это первое что я сделал! результат — только один из форума, где чел пишет что запустил эту мфу а как это сделать.
    http://forum.ubuntu.ru/index.php?PHPSESS >

    там дрова более старые.
    попробовал,пишет — ошибка, более новая версия уже установлена.

    как удалить дрова которые установил ранее GDebi?

    источник

    Добавить комментарий

    Adblock
    detector