Меню Рубрики

Установка draftsight 32 bit

Установка бесплатного кроссплатформенного 2D CAD (САПР) DraftSight в Kubuntu 12.10 x86-64

Комментарии (22)

Давно уже стоит. Препод по начерталке ло сих пор считает, что это autocad ))

Это точно, стоит давно, да никто не удосужился статейку черкануть. А я вот себя гадом чувствую, год назад хотел написать но то времени нет, то лень.
Автору респект и уважуха. Остальным побольше таких постов.

Вот единственное, что меня смущает — непонятка (для меня) вот в этом фрагменте:
«1. Вам предоставляется персональная, неисключительная, не подлежащая передаче другому лицу, бесплатная и временная лицензия »
Слово «временная лицензия» в обычном контексте (да и в смысле всего текста) меня определенно напрягает. -(
то есть, в принципе, в любой момент при выпуске релиза(например) могут сказать — так, временная лицензия перестала работать, покупайте полную версию.

полная лицензия этой программы позволяет обращаться к онлайн помощи. Простая лицензия дает только саму программу.
во многих оупенсорсных проектах миенно так и есть, если разобраться. Полная свобода только в GNU программах по сути.

Я консультировался с представительством. В общем и целом ты прав — в любой момент они могут отозвать лицензию.

могут, но раз уж деб файл вышел в сеть, так уж нечего им не поделать, хоть та версия, что сейчас, никуда не денется..

Я бы не был таким оптимистом.

да, ну тогда придеться крэкнутым автокадом пользоваться или искать еще чего-нибудь.

Может и не придётся. Дело в том, что есть библиотека (свободная), которая позволяет прикрутить формат DWG хоть к LibreOffice. Но вся беда в том, что за каким-то хреном её загнали под гнутую лицензию третей версии. И старый козлина Столлман это дерьмо всячески поддержал. Вот теперь разработчики LibreCAD уже несколько месяцев буцкаются с авторами библиотеки. Но дело вроде сдвинулось с мёртвой точки. Так что вполне возможно появление поддержки DWG в LibreCAD и будем мы тогда плевать хотеть на автодесковскую жутко дорогую поделку.

Авторы не смогли динамическую линковку? о.0

Ну оффис я так считаю предназначен немнога для других целей. Это же САПР, причем достойный, который в праве может конкурировать с автокадом.
И всеже, смотря от куда он запускаеться, становится груснее, он стартует из run файла, а значит он закрытый, и исходный код для народа никто не форканет((((( А ведь эта программа идеальна для моих небольших студенчиских работ.

На счёт офиса это был юмор. Ну а на счёт LibreCAD там действительно идёт какое-то дурное буцкалово. Впрочем, в ближайшее время вроде как всё должно разрешиться. Посмотрим, короче.

И я ещё одного момента не понимаю: есть же коммерческий вариант, который зовётся BrisCAD. Если так необходимо, то можно купить его. Ну или взломать. 🙂 По старой маздайной привычке.

Кстати, в нём какое-то удобство или полезные функции по сравнению с DraftSight Вами были замечаны?

Я его не использовал. Но когда искал альтернативы, то просматривал и его сайт. Спам они мне до сих пор шлют. 🙂

ну я, например, при поиске нашел варикад, и что оказалось для меня немаловажным, вместе средствами лечения.
ибо те задачи, для которых я использовал варикад (планы зданий, с прокладкой кабелей), увы требуют полнорабочей версии того же варикада.
благо с двг у него проблем нет. 🙂

источник

draftsight на ubuntu 14.04 (32-разрядная ОС)

У меня Ubuntu 14.04 LTS (тип Os 32bit) на AMD 64 X2. Я хотел бы установить Draftsight , но это кажется совершенно невозможным: сначала он говорит, что имеет неправильную версию программного обеспечения архитектуры (я установил все пакеты i386), но в конце концов она всегда вызывает ошибку

Возможно ли установить такое программное обеспечение на 32-битных Ubuntu и AMD?

Есть ли версия программного обеспечения, совместимого с моей конфигурацией? мне нужно загрузить более старую версию?

3 ответа

Возможно ли установить 64-разрядную ОС или это не поддерживается вашим оборудованием? В Linux 64-битный «нормальный», и большинство программ предназначены для 64-битных в первую очередь.

Мне удалось установить и запустить 64-битный новый DraftSight в 32-битной системе Ubuntu (конечно, на 64-битном процессоре). Без (или очень мало) грязных хаков.

Читайте также:  Установка измерительная высоковольтная hva30

Резюме

    Ключом к решению является возможность установки и запуска ядра amd64 в системе i386 Ubuntu путем добавления репозитория amd64 в качестве источника для пакетов.

Тогда установка 64-бит .deb должна была быть простой задачей. Тем не менее, была проблема, связанная с тем, что для сценария установки пакета требуется дополнительная библиотека amd64, необходимая для предварительного запуска. (Это не было вызвано зависимостями пакета.)

  • Решение: apt-get install libgtk2.0-0:amd64 .

Затем установленный исполняемый файл DraftSight не запускался, потому что некоторые библиотеки amd64 все еще отсутствовали (также неправильно отражены формальными зависимостями пакета). Во-первых, он не мог ссылаться на отсутствующую динамическую библиотеку ( .so );

  • Решение: apt-get install libgl1-mesa-glx:amd64

второй, он отказался запускать отчет о том, что некоторые из плагинов не могут быть загружены. Установка некоторых пакетов amd64 в конечном итоге сделала трюк; и теперь он работает.

  • apt-get install libcanberra-gtk-module:amd64 gtk2-engines-murrine:amd64
  • dpkg —extract overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb / (Фактически, apt-get install overlay-scrollbar-gtk2:amd64 отлично работает в 15.10 (Wily) , нет необходимости в грязном хаке!)
  • (возможно, необязательно) apt-get install libgstreamer0.10-0:amd64 gstreamer0.10-plugins-base:amd64 libnss-mdns:amd64 libodbc1:amd64 libgnomeui-0:amd64 libmng2:amd64
  • Я экспериментировал с 15.04 (Vivid) / i386 и с последним draftSight.deb , версия которого сообщается dpkg следующим образом:

    1. с использованием ядра amd64

    и перезагрузитесь в новое ядро. (Конечно, у вас должно быть резервное ядро ​​i386 другой версии, которая уже установлена ​​и протестирована для обеспечения безопасности.)

    (Я узнал, что это стало возможным благодаря советам Ссылка . В целом это хорошо работает: на одном компьютере из моего, без каких-либо проблем. Другой компьютер с другим аппаратным ботинком нестабильным образом — Ссылка .)

    Вы можете установить специальный пакет linux-image-extra -. -generic вместо последней вышеприведенной команды (которая будет тянуть меньше зависимостей). (В моем случае я использую linux-image-extra-3.19.0-28-generic .)

    2. установка draftSight.deb

    Чтобы установить draftSight.deb и полагаться на машину APT, чтобы вытащить все зависимости, я использовал простой инструмент gdebi (стандартный «программный центр» Ubuntu подходит для этой задачи так же хорошо теоретически), что у меня было обнаружено благодаря Безопасно ли использовать gdebi вместо Ubuntu Software Center для установки файлов .deb? , gdebi vs dpkg: Как gdebi автоматически получает недостающие зависимости? Могу ли я использовать gdebi для всех других установок пакетов .deb? .

    Однако возникла проблема с требованием сценария установки:

    Итак, давайте посмотрим на требуемый, но пропустим libgtk-x11-2.0.so.0 (предположительно, amd64):

    После этого установка прошла успешно.

    3. Запуск его работы

    Раньше было праздновать успех.

    В меню появилось меню DraftSight, но оно не запустилось. Поэтому я хотел запустить его из командной строки. Это не путь. (Теперь я думаю, что, возможно, он добавил путь к системному bash_profile или тому подобное, но я не переписывался, чтобы получить новую переменную среды.) Давайте ищем его исполняемый файл:

    и запустите его, и увидите ошибки:

    На самом деле оказалось, что настроек PATH нет, поэтому я сделал:

    отсутствует библиотека amd64, которая связана с

    Снова, ищем недостающую библиотеку amd64:

    он не загружает плагины

    canberra-gtk-module и murrine

    Итак, пытаясь преодолеть это. overlay-scrollbar для amd64 нелегко устанавливается.

    После этого появляется гораздо меньше сообщений об ошибках:

    overlay-scrollbar (багги-зависимости в Ubuntu 15.04 (Vivid)? Не в 15.10 (Wily))

    (Фактически, apt-get install overlay-scrollbar-gtk2:amd64 отлично работает в 15.10 (Wily) , нет необходимости читать что-либо ниже! 15.04 (Vivid) имеет эту проблему с overlay-scrollbar-0.2.16+r359+15.04.20150319-0ubuntu1 , 15.10 (Wily) не делает есть эта проблема с overlay-scrollbar-0.2.17.1+15.10.20150604.1-0ubuntu1 . Нет других версий в репозиториях Ubuntu overlay-scrollbar , я проверил это, чтобы узнать, существует ли резервная копия версии Wily.)

    Один из вариантов теперь взломал немного (мой первоначальный выбор, см. ниже); другой устанавливает пакеты из Wily (это чище, потому что тогда все состояние установленных пакетов отслеживается в базе данных dpkg):

    Другой вариант — взломать бит:

    Удалены установленные пакеты наложения-прокрутки, чтобы узнать URL-адреса файлов .deb:

    Установленные обратно временно удаленные пакеты i386:

    Снова увидив ошибки ошибок багги во время прямой установки (я говорю, что он хочет пакет, который действительно уже установлен! TODO: сообщите об этом как об ошибке для Ubuntu!):

    Теперь проблема заключается в том, что APT непригодна для использования, поскольку обнаруживает поврежденную зависимость:

    Чтобы преодолеть это, мне пришлось бы всегда временно удалять overlay-scrollbar-gtk2: amd64 (или удалять его только формально из базы данных) и восстанавливать его силой, когда DraftSight понадобится для запуска.

    Я «придумал» глупый способ установить библиотеку, но не касаясь базы данных пакета. Вместо dpkg —force-depends —install , выполните:

    с помощью strace, чтобы найти любые другие отсутствующие библиотеки

    Вот простой способ отфильтровать не найденные библиотеки, которые я могу надеяться получить от Ubuntu, т. е. в стандартных местах, таких как / usr / lib / и / lib / — /lib/ , выполняется поиск сначала /usr/lib/ , это объясняет мою фильтрацию (если последнее место, в котором оно искалось, не имело его, значит, оно не было найдено):

    Итак, я установил библиотеки gstreamer amd64 на всякий случай:

    (И еще некоторые недостающие библиотеки: libnss-mdns:amd64 libodbc1:amd64 libgnomeui-0:amd64 libmng2:amd64 .)

    источник

    draftsight на ubuntu 14.04 (32-разрядная ОС)

    У меня Ubuntu 14.04 LTS (тип Os 32bit) на AMD 64 X2. Я хотел бы установить Draftsight , но это кажется совершенно невозможным: сначала он говорит, что имеет неправильную версию программного обеспечения архитектуры (я установил все пакеты i386), но в конце концов она всегда вызывает ошибку

    Возможно ли установить такое программное обеспечение на 32-битных Ubuntu и AMD?

    Есть ли версия программного обеспечения, совместимого с моей конфигурацией? мне нужно загрузить более старую версию?

    3 ответа

    Возможно ли установить 64-разрядную ОС или это не поддерживается вашим оборудованием? В Linux 64-битный «нормальный», и большинство программ предназначены для 64-битных в первую очередь.

    Мне удалось установить и запустить 64-битный новый DraftSight в 32-битной системе Ubuntu (конечно, на 64-битном процессоре). Без (или очень мало) грязных хаков.

    Резюме

      Ключом к решению является возможность установки и запуска ядра amd64 в системе i386 Ubuntu путем добавления репозитория amd64 в качестве источника для пакетов.

    Тогда установка 64-бит .deb должна была быть простой задачей. Тем не менее, была проблема, связанная с тем, что для сценария установки пакета требуется дополнительная библиотека amd64, необходимая для предварительного запуска. (Это не было вызвано зависимостями пакета.)

    • Решение: apt-get install libgtk2.0-0:amd64 .

    Затем установленный исполняемый файл DraftSight не запускался, потому что некоторые библиотеки amd64 все еще отсутствовали (также неправильно отражены формальными зависимостями пакета). Во-первых, он не мог ссылаться на отсутствующую динамическую библиотеку ( .so );

    • Решение: apt-get install libgl1-mesa-glx:amd64

    второй, он отказался запускать отчет о том, что некоторые из плагинов не могут быть загружены. Установка некоторых пакетов amd64 в конечном итоге сделала трюк; и теперь он работает.

  • apt-get install libcanberra-gtk-module:amd64 gtk2-engines-murrine:amd64
  • dpkg —extract overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb / (Фактически, apt-get install overlay-scrollbar-gtk2:amd64 отлично работает в 15.10 (Wily) , нет необходимости в грязном хаке!)
  • (возможно, необязательно) apt-get install libgstreamer0.10-0:amd64 gstreamer0.10-plugins-base:amd64 libnss-mdns:amd64 libodbc1:amd64 libgnomeui-0:amd64 libmng2:amd64
  • Я экспериментировал с 15.04 (Vivid) / i386 и с последним draftSight.deb , версия которого сообщается dpkg следующим образом:

    1. с использованием ядра amd64

    и перезагрузитесь в новое ядро. (Конечно, у вас должно быть резервное ядро ​​i386 другой версии, которая уже установлена ​​и протестирована для обеспечения безопасности.)

    (Я узнал, что это стало возможным благодаря советам Ссылка . В целом это хорошо работает: на одном компьютере из моего, без каких-либо проблем. Другой компьютер с другим аппаратным ботинком нестабильным образом — Ссылка .)

    Вы можете установить специальный пакет linux-image-extra -. -generic вместо последней вышеприведенной команды (которая будет тянуть меньше зависимостей). (В моем случае я использую linux-image-extra-3.19.0-28-generic .)

    2. установка draftSight.deb

    Чтобы установить draftSight.deb и полагаться на машину APT, чтобы вытащить все зависимости, я использовал простой инструмент gdebi (стандартный «программный центр» Ubuntu подходит для этой задачи так же хорошо теоретически), что у меня было обнаружено благодаря Безопасно ли использовать gdebi вместо Ubuntu Software Center для установки файлов .deb? , gdebi vs dpkg: Как gdebi автоматически получает недостающие зависимости? Могу ли я использовать gdebi для всех других установок пакетов .deb? .

    Однако возникла проблема с требованием сценария установки:

    Итак, давайте посмотрим на требуемый, но пропустим libgtk-x11-2.0.so.0 (предположительно, amd64):

    После этого установка прошла успешно.

    3. Запуск его работы

    Раньше было праздновать успех.

    В меню появилось меню DraftSight, но оно не запустилось. Поэтому я хотел запустить его из командной строки. Это не путь. (Теперь я думаю, что, возможно, он добавил путь к системному bash_profile или тому подобное, но я не переписывался, чтобы получить новую переменную среды.) Давайте ищем его исполняемый файл:

    и запустите его, и увидите ошибки:

    На самом деле оказалось, что настроек PATH нет, поэтому я сделал:

    отсутствует библиотека amd64, которая связана с

    Снова, ищем недостающую библиотеку amd64:

    он не загружает плагины

    canberra-gtk-module и murrine

    Итак, пытаясь преодолеть это. overlay-scrollbar для amd64 нелегко устанавливается.

    После этого появляется гораздо меньше сообщений об ошибках:

    overlay-scrollbar (багги-зависимости в Ubuntu 15.04 (Vivid)? Не в 15.10 (Wily))

    (Фактически, apt-get install overlay-scrollbar-gtk2:amd64 отлично работает в 15.10 (Wily) , нет необходимости читать что-либо ниже! 15.04 (Vivid) имеет эту проблему с overlay-scrollbar-0.2.16+r359+15.04.20150319-0ubuntu1 , 15.10 (Wily) не делает есть эта проблема с overlay-scrollbar-0.2.17.1+15.10.20150604.1-0ubuntu1 . Нет других версий в репозиториях Ubuntu overlay-scrollbar , я проверил это, чтобы узнать, существует ли резервная копия версии Wily.)

    Один из вариантов теперь взломал немного (мой первоначальный выбор, см. ниже); другой устанавливает пакеты из Wily (это чище, потому что тогда все состояние установленных пакетов отслеживается в базе данных dpkg):

    Другой вариант — взломать бит:

    Удалены установленные пакеты наложения-прокрутки, чтобы узнать URL-адреса файлов .deb:

    Установленные обратно временно удаленные пакеты i386:

    Снова увидив ошибки ошибок багги во время прямой установки (я говорю, что он хочет пакет, который действительно уже установлен! TODO: сообщите об этом как об ошибке для Ubuntu!):

    Теперь проблема заключается в том, что APT непригодна для использования, поскольку обнаруживает поврежденную зависимость:

    Чтобы преодолеть это, мне пришлось бы всегда временно удалять overlay-scrollbar-gtk2: amd64 (или удалять его только формально из базы данных) и восстанавливать его силой, когда DraftSight понадобится для запуска.

    Я «придумал» глупый способ установить библиотеку, но не касаясь базы данных пакета. Вместо dpkg —force-depends —install , выполните:

    с помощью strace, чтобы найти любые другие отсутствующие библиотеки

    Вот простой способ отфильтровать не найденные библиотеки, которые я могу надеяться получить от Ubuntu, т. е. в стандартных местах, таких как / usr / lib / и / lib / — /lib/ , выполняется поиск сначала /usr/lib/ , это объясняет мою фильтрацию (если последнее место, в котором оно искалось, не имело его, значит, оно не было найдено):

    Итак, я установил библиотеки gstreamer amd64 на всякий случай:

    (И еще некоторые недостающие библиотеки: libnss-mdns:amd64 libodbc1:amd64 libgnomeui-0:amd64 libmng2:amd64 .)

    источник

    compizomania

    Азбука в Linux для начинающих и не только. Я знаю только то, что ничего не знаю, но другие не знают и этого. Сократ

    Страницы

    12 апреля 2014

    Установить DraftSight в Ubuntu

    DraftSight является проприетарной бесплатной 2D САПР (системы автоматизированного проектирования и автоматизированной разработки) продукт для инженеров, архитекторов, дизайнеров, студентов и преподавателей. Продукт был разработан Dassault Systemes и позволяет пользователям создавать, редактировать и просматривать DWG и DXF файлы.
    DWG-файлы содержат двоичные данные для проектирования CAD и этот формат используется многими программами САПР. DWG является стандартом де-факто в современном проектировании. DXF формат файла используется для преобразования CAD файлов в универсальный формат, который можно прочитать в других программах САПР.
    Язык интерфейса русский. http://compizomania.blogspot.com/

    Полная поддержка DWG/DXF файлов, чтение/запись
    Сохранение чертежей в формате DWT/DWG/DXF предыдущих версий (требуется активация по Email)
    Создание бинарных или ASCII DXF файлов
    Внедрение растровых файлов (.bmp, .gif, .jpg, .jpeg, .png, .tif, & .tiff)
    Внедрение ссылок внешних чертежей
    Печать чертежей в формат файлов .plt, .jpg, .pdf, .png, & .svg
    Сохранение в форматы .wmf?, .jpeg, .pdf, .png, .sld, .svg, .tif, & .stl
    Создание много-страничных PDF файлов
    Публикация для eDrawings
    Экспорт в форматы файлов *.bmp, *.emf, *.jpg,*.pdf, *.png, *.sld,*.svg, *.tiff

    Ускановка DraftSight в Ubuntu

    Вы можете загрузить пакет DraftSight с официального сайта продукта: http://www.3ds.com/ru/produkty-i-uslugi/draftsight/zagruzit-draftsight/ или выполнить следующую команду в терминале:

    cd /tmp && wget http://www.draftsight.com/download-linux-ubuntu && sudo dpkg -i download-linux-ubuntu

    Во время установки DraftSight необходимо принять Лицензионное соглашение:

    А также активировать продукт, указав адрес своей эл.почты или сделать это позже:

    По завершении установки вы найдёте DraftSight в программах Графика или поиском в меню:

    источник

    Добавить комментарий

    Adblock
    detector