Меню Рубрики

Установка dude на mikrotik routerboard 333

Создание домашней сети на базе устройств MikroTik: Часть 8 – Установка и настройка MikroTik DUDE Network Monitor

Цикл статей по организации единой локальной сети с маской (255.255.255.0)24 на большом удалении объектов друг от друга.
В прошлой части, мы с Вами, настроили правильное перенаправление портов в сети с двумя шлюзами.

В этой статье, я бы хотел поговорить про то, как за всем этим зоопарком следить. Чтобы никто, никуда не убежал или не вышел за рамки своих обязанностей =)
Вообще в интернете существует достаточно различных систем мониторинга. Взять хотя бы такие вещи, как Zabbix, Graphite, Grafana и иже с ними.
Очень большая гибкость. куча плагинов, возможность писать свои собственные плагины, выводят эти системы в разряд самых используемых не только среди энтузиастов, но и среди корпораций.
Работа серверов, работа различных служб на этих серверах. Мгновенное оповещение при возникновении ошибок.
Все это очень необходимо при широком парке различного оборудования.

А теперь давайте взглянем со стороны не совсем рядового пользователя. Т.е. нас, тех, кто делает мини офис у себя дома.
Лично мне все эти системы не очень нравятся, хоть они и популярны. Да и сама идея мониторинга домашнего железа – это по большому счету “игрушка”, на первый взгляд не дающая практической пользы.

Тем не менее, я решил попробовать реализовать эту “игрушку” у себя. Благо роутер RB750Gr3 позволяет установить в себя microSD карту и на неё положить базу данных.

Знакомьтесь,
The Dude
Сетевой монитор Dude – это приложение от Латвийской компании MikroTik, которое может значительно улучшить работу сетевой среды. Он автоматически сканирует все устройства в определенных подсетях, рисует и компонует карту сетей, отслеживает службы устройств и предупреждает, если у некоторых служб есть проблемы.
Можно не только контролировать свои устройства, но и управлять ими. Поддержка массового обновления устройств на RouterOS и настройка их прямо из Dude Client.

Вот некоторые из его функций:
– Автоматическое обнаружение и компоновка сети
– Обнаруживает любой тип или марку устройства
– Устройство сети, мониторинг каналов и уведомления
– Включает иконки SVG для устройств и поддерживает пользовательские значки и фоны
– Простая установка и использование
– Позволяет создавать собственные карты и добавлять пользовательские устройства
– Поддерживает мониторинг SNMP, ICMP, DNS и TCP для устройств, которые его поддерживают
– Мониторинг использования отдельных линков и графики по ним
– Прямой доступ к средствам дистанционного управления для управления устройствами
– Работает в средах Linux Wine, MacOS Darwine и Windows

В интернете можно найти статьи по установке серверной части The Dude на Ваш ПК, но они уже достаточно устарели.
Компания MikroTik убрала поддержку локальных серверов Dude и оставила возможность его работы исключительно под RouterOS.
Что это значит?
А это значит, что данная служба может быть установлена исключительно на операционную систему RouterOS компании MikroTik, которая в свою очередь может быть установлена отдельно на x86 машину или на виртуальную среду(VirtualBox, Proxmox и др.). Ну или, как наш вариант, уже находится в роутере.
На странице загрузок можно увидеть какое оборудование поддерживает установку The Dude server:
– архитектура TILE: все CCR
– архитектура ARM: LDF ac, LHG ac, SXTsq (ac series), Wireless Wire, cAP ac, hAP ac², CRS3xx, RB3011, RB1100AHx4
– архитектура x86: RB230, X86
– архитектура MMIPS: RB750Gr3, RBMxx

Как видим, в этом списке есть наш RB750Gr3. Это не может не радовать! Давайте установим серверную часть.
Вот только перед этим, нам понадобится microSD карта. Я рекомендую брать до 8Гб. Больше вряд ли понадобится. Её необходимо установить в RB750Gr3
Но если у Вас нет под рукой SD карты, это не страшно, есть еще обычный USB2.0 разъем. И базу данных можно расположить на обычной флешке.

У меня как раз оказалась SD карта под рукой.

1. Установка пакета The Dude на роутер RB750Gr3
Установка накопителя
На выключенном роутере устанавливаем в него SD карту (или USB флешку)

Подготавливаем флешку к работе.
Форматируем её в формат ext3.
Этот формат будет самым лучшим. т.к. он надежней пресловутого Fat32 и размер одного файла может быть большим.
[code]/disk eject-drive 0[/code] [code] /disk format-drive 0 file-system=ext3
formatted: 100%
[/code] Консольно: Перед форматированием диск нужно отмонтировать.

Читайте также:  Установка акриловых ванн в одинцово

Скачиваем и устанавливаем пакет The Dude
Теперь, когда наша SD карта готова к использованию, настало время установить пакет сервера в систему.
На момент написания статьи у меня установлена прошивка 6.40.7, скачиваемый пакет к ней называется dude-6.40.7-mmips.npk
Также можно сразу скачать установщик клиента той же версии, что и сервер dude-install-6.40.7.exe

У нас есть пакет сервера, настало время его загрузить в роутер.
Это можно сделать разными способами (Winbox drag’n’drop, webfig, ftp или sftp). Я предпочитаю Winbox.
Просто открываю Files и перетаскиваю в него файл dude-6.40.7-mmips.npk

Просто перезагружаем роутер и пакет установится автоматически.
[code]/system reboot[/code] Консольно: Подтверждаем ребут Y/N

Настройка и запуск службы
Сейчас нам нужно изменить путь хранения данных для Сервера
[code]/dude set data-directory=”/disk1/dude”[/code] Консольно: Указываем папку, где будут храниться все данные сервера

Запускаем сервер
[code]/dude set enabled=yes[/code] Консольно:

О корректной работе будет говорить статус Running и наличие в списке файлов большого дерева /disk1/dude
[code] /dude print
enabled: yes
data-directory: /disk1/dude
status: running
[/code] Консольно:

Теперь мы можем подключиться к серверу удаленно через клиент The Dude

2. Подключение к The Dude и начало настройки
Для начала установим на наш ПК или ноутбук утилиту The Dude Client
Установка выполняется стандартным способом, как и любой другой программы: Запускаете установщик dude-install-6.40.7.exe и нажимаете Далее, Далее, Далее и т.д. =)

К сожалению ярлык на рабочем столе не создается.
Поэтому идем по пути установки и создаем его самостоятельно.

Запускаем клиент
Вводим данные своего пользователя для входа. Можем сохранить их для дальнейшего быстрого подключения и нажать Connect
Подключение может занять достаточное время. Не пугайтесь. просто нужно чуть-чуть подождать.
Эти данные говорят о том, что идет подключение и обмен данными с сервером

После подключения мы увидим рабочее пространство:
Рекомендую отказаться от сканирования сети и добавлять все в ручную.
Далее я расскажу, как добавить устройство и сеть для отображения.
Все остальное будет ограничено Вашим желанием дальнейшего изучения.

Попробуем добавить наш девайс на карту и включим мониторинг нескольких параметров: Процессора, Памяти и Диска
Нажимаем правой кнопкой мыши на пустом пространстве и выбираем Add Device Вводим IP адрес нашего сервера. Именно его и будем контролировать пока что. Не забываем указать наш Login и пароль для подключения и что это RouterOS Начинаем добавлять контролируемые сервисы Выбираем нужный нам сервис и добавляем его Делаем тоже самое для служб CPU, Memory и Disk Как мы можем видеть, часть параметров находится в состоянии down
Это означает, что либо сервис действительно вышел из строя (что невозможно т.к. мы подключены к серверу), либо не запущен SNMP на роутере.
Давайте проверим это:

Включаем SNMP на RouterOS
Подключаемся по WinBox к роутеру и настраиваем SNMP для локальной сети
В принципе к community можно не заходить. Его нужно использовать только если Вы хотите сделать защищенную группу. Но мы в домашней локальной сети и нам эти излишки не нужны

Давайте проверим, работает ли SNMP
Нажимаем правой кнопкой мыши на нашем добавленном устройстве и выбираем Snmpwalk Как видим, все работает, данные мы получаем. Как видим все данные получаем и даже строятся графики PS*
Да, пришлось развернуть CHR для демонстрации =))

Давайте добавим сеть и посмотрим, с какой скоростью работает сетевой интерфейс.
Ну и поставим иконку Роутера.
Добавим известную нам сеть Записываем название сети и задаем Всю сеть целиком Теперь свяжем нашу сеть и роутер обычным линком Кликаем мышью на наш роутер и не отпуская кнопку мыши тащим линию к сети пока она не зафиксируется Выбираем нужные параметры. Вместо SNMP можно выбрать еще RouterOS видим скорость работы интерфейса и график Для изменения параметров устройства нужно кликнуть на нем дважды Вот с такой маленькой сети можно начать работу с The Dude

У меня уже заведены все мои устройства в локальной сети, добавлены изображения, написаны различные функции и это еще не все.
Вы сможете сделать не хуже, я уверен в Вас. Дерзайте!
Ну и на последок:
Это уже практическая домашняя сеть

Читайте также:  Установка забора с профилями

На этом цикл статей по организации единой локальной сети можно считать законченным.
Хотя есть еще пара моментов, которые стоит описать, но это будут отдельные статьи не в рамках цикла.

Спасибо за Ваше время. Надеюсь Вам было интересно!!

Список всех статей в хронологическом порядке: История статей

UPD: 11.03.2019 – Архив с изображениями для оформления The Dude
Скачать архив Вы сможете на одноименной странице Иконки The Dude. Оставлять пожелания по иконкам можно в этой теме в комментариях. Не факт, что все учту, но буду стараться 😉

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

источник

Установка dude на mikrotik routerboard 333

Настройка оборудования MikroTik

Резервирование, агрегация, VPN, скрипты для решения нестандартных задач.

Наставьте на путь истинный пожадуйста

Имеется в наличии сей девайс: RouteBoard RB951Ui-2HnD. Понимаю что не самый навроченный.
Так вот не нашел я внутри его системы мониторинга Dude

Возникают на следующие вопросы

1. А Dude устанавливается вообще на реальное железо производителем этих устройств ?
2. Все ли модели Mikrotik поставляются без установленного на них пакета Dude ? Или я чего-то не понимаю и этот пакет не предназначен для установки на некоторые модели Mikrotik ?
3. Можно ли средствами самого Mikrotik доустановить этот пакет на него ? Как это сделать ?
4. Наверно на этот пакет потребуется отдельная лицензия ?

Ну и отдельный вопрос. возможно ли на нем настроить Dude так чтобы он посылал смс когда
1. прпадет интернет на порту WAN ?
2. протрассировать путь от меня до провайдера и сообщить по смс что где-то имеется проблема ?
3. сообщить по смс что загрузка через него выросла больше заданной величины ?
4. измерить скорость от меня до провайдера и если она сильно упала (стала меньше заданной величины) сообщить об этом по смс ?

Или я туплю и хочу слишком многого от простой железки.
Заранее спасибо всем ответивгим по существу. на флуд нет времени. шеф рвет и мечет.

1. Да, но смотреть ниже :
System requirements for server package
RouterOS:
v6.34rc13 or newer
Hardware:
Tile — CCR series hardware
ARM — RB3011, RB1100AHx4 Dude Edition (RB1100Dx4)
mmips — hEX (RB750Gr3)
RouterOS x86 installations
RouterOS CHR environment

Ну и отдельный вопросы — как Вы педствляете отпрвку смс, если «пропадет интернет на порту WAN» ?

mafijs писал(а): 1. Да, но смотреть ниже :
System requirements for server package
RouterOS:
v6.34rc13 or newer
Hardware:
Tile — CCR series hardware
ARM — RB3011, RB1100AHx4 Dude Edition (RB1100Dx4)
mmips — hEX (RB750Gr3)
RouterOS x86 installations
RouterOS CHR environment

Ну и отдельный вопросы — как Вы педствляете отпрвку смс, если «пропадет интернет на порту WAN» ?

Так и не понял ничего ? Можно чуть подробнее. заранее спасибо за ответы.

Ну если пропадет интернет на WAN, естественно надо будет докручивать GSM модем к Mikrotik. что наверное сделать не получится. я так думаю.

А для каких моделей Mikrotik существуют Dude-server, который уже установлен исходно производителем в нем ?
Или Dude-Server надо будет все равно потом доустанавливать самому ? Тогда как это сделать средствами самого Mikrotik ?
Или только поможет перепрошивка ? И кто это может сделать и в какую цену ?

Что можете сказать об этих вопросах
Ну и отдельный вопрос. возможно ли на нем настроить Dude так чтобы он посылал смс когда
1. прпадет интернет на порту WAN ?
2. протрассировать путь от меня до провайдера и сообщить по смс что где-то имеется проблема ?
3. сообщить по смс что загрузка через него выросла больше заданной величины ?
4. измерить скорость от меня до провайдера и если она сильно упала (стала меньше заданной величины) сообщить об этом по смс ?

Мой девайс к счастью работает. и его ремонтировать не надо. меня интересуют вот эти четыре вопроса которые написаны выше.

Сдаётся мне, что вы не представляете себе какие сложные это задачи?

Читайте также:  Установка поилки для шиншилл

Рекомендую ознакомится https://wiki.mikrotik.com/wiki/Manual:T . ifications
DUDE «из коробки» не умеет из ваших хотелок ничего.

Читайте про
Zabbix и про Paessler PRTG, благо последний, даже в режиме фриваре полностью функционален, ограничение только на количество датчиков.

Но и даже эти очень функциональные средства потребуют: дополнительного оборудования, времени, сил, средств.
Я для местного провайдера огранизовывал мониторинг оборудования на базе PRTG, он делает практически все, что желаете, кроме измерения скорости. И в него вложено средств, времени, сил. просто ума.

источник

Установка dude на mikrotik routerboard 333

Hello,
I just got a Routerboard 1100 and need to install Dude server on it.
Got the server from mikrotik.com (PPC) copied into root folder, rebooted the routerboard. In the logs I got that Dude server is installed but I cannot find it anywhere. I got just a file into packages and when I try to enable it the server shows in log «package dude is unscheduled by admin».

Re: How to install Dude server on Routerboard 1100?

you don’t need to enable it. it works right after upload and reboot.
unscheduled in log simply means you cancelled uninstall, this has no relevance to the issue.

you will not see any trace of Dude server in RouterOS. to use it, connect with Dude windows client application to the RouterOS IP address.

Re: How to install Dude server on Routerboard 1100?

Tnx for the reply normis.
I have downloaded and installed dude for windows from mikrotik website, tried to connect to my router ip and in the lower left corner I have an error witch I cannot read it: «Error: Connect fail: No connection could be made because the tha. «

How can I see the whole text of that error?

I must tell you that on mikrotik website, wiki and forum I cannot find any information about installing and using the dude from RouterOs. How can a user guess that he have to install the dude for windows to access the dude server on routeros?

Re: How to install Dude server on Routerboard 1100?

sorry, the error message is cut off because of a known problem, it will be fixed in the future.

There is no way to use The Dude from RouterOS. It’s just a server/agent. It has no interface, you must use the Dude windows program to connect to it. You can also use the web interface, but that will require another PC anyway.

make sure your RouterOS is not blocking the connection with any Input chain firewall rules.

Re: How to install Dude server on Routerboard 1100?

It’s a new routerboard 1100, with no firewall rules.
I got it for testing and bridged all the ethernet to bridge1.
I can connect to that IP with winbox, but dude got that error.

What could be wrong there?

Re: How to install Dude server on Routerboard 1100?

show me the output of «/system package print»

and «/ip address print» and also «/ip firewall export»

Re: How to install Dude server on Routerboard 1100?

[admin@MikroTik] > /system package print
Flags: X — disabled
# NAME VERSION SCHEDULED
0 system 5.0beta4
1 dhcp 5.0beta4
2 X ipv6 5.0beta4
3 hotspot 5.0beta4
4 mpls 5.0beta4
5 security 5.0beta4
6 routing 5.0beta4
7 X wireless 5.0beta4
8 routeros-powerpc 5.0beta4
9 routerboard 5.0beta4
10 ppp 5.0beta4
11 dude 4.0beta2
12 advanced-tools 5.0beta4

[admin@MikroTik] > /ip address print
Flags: X — disabled, I — invalid, D — dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 ;;; default configuration
80.97.140.241/24 80.97.140.0 80.97.140.255 bridge1

[admin@MikroTik] > /ip firewall export
# jan/02/1970 02:16:56 by RouterOS 5.0beta4
# software > #
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-timeout=10s \
tcp-established-timeout=1d tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s \
tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=»place hotspot rules here» disabled=yes
add action=masquerade chain=srcnat comment=»masquerade hotspot network» disabled=no src-address=10.5.50.0/24
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no

источник

Добавить комментарий

Adblock
detector