Меню Рубрики

Установка eclipse luna ubuntu

Установка Eclipse в Ubuntu 16.04

Eclipse — это очень популярная среда разработки с открытым исходным кодом, которая поддерживает огромное количество разных языков программирования. Первая версия среды вышла в 2004 году и изначально она поддерживала только Java. На данный момент же поддерживаются такие языки, как C++, Ada, PHP, Cobol, Fortran, X10, JavaScript, Perl, Python, Ruby и многие другие.

Среда разработки Eclipse может использоваться как в Linux так и в Windows. Не так давно состоялся релиз новой версии среды — Eclipse Neon. В этой статье мы рассмотрим как выполняется установка Eclipse Ubuntu 16.04, и нас будет интересовать именно последняя версия.

Установка Eclipse на Ubuntu

Для работы Eclipse в вашей системе должна быть установлена Java машина. Вы можете ее установить с помощью такой команды:

sudo apt install openjdk-7-jdk

Чтобы получить последнюю версию Eclipse вам необходимо скачать установщик программы из официального сайта.

Тут вы можете загрузить не только сам установщик, но и пакеты для поддержки разных языков программирования. После того, как установщик будет загружен, перейдите в папку с файлом и распакуйте его, например, для 64 битной версии команда будет выглядеть вот так:

tar xf eclipse-inst-linux64.tar.gz

Перейдите в папку установщика:

Запустите установщик без прав суперпользователя для его обновления:

Обратите внимание на желтый треугольник в верхнем правом углу. Для обновления нажмите на нем и выберите Update.

После завершения обновления закройте установщик. Дальше установка. Вы можете устанавливать ее с правами суперпользователя или без них. Если хотите установить среду в домашнюю папку выполните:

Затем выберите версию IDE для вашего языка:

И выберите путь в вашей домашней папке для установки:

Также можно использовать sudo, тогда программа будет установлена в папку /opt:

После завершения установки вы можете запустить программу:

Но это еще не все нам осталось создать ярлык для главного меню и рабочего стола. Создайте файл

/.local/share/applications/eclipse.desktop со следующим содержимым:

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Name=Eclipse IDE
Comment=Eclipse Integrated Development Environment
Icon=/opt/eclipse/java-neon/eclips/icon.xpm
Exec=/opt/eclipse/java-neon/eclips/eclipse
StartupNotify=true
StartupWM >

Чтобы разрешить запускать этот ярлык выполните команду:

Готово, теперь установка Eclipse Ubuntu 16.04 завершена и вы можете использовать новую версию программы.

Установка Eclipse с помощью apt

Если вам не нужна самая новая версия, то вы можете установить Eclipse Ubuntu 16.04 из официальных репозиториев. Это намного проще чем в предыдущем варианте. Достаточно выполнить:

Пакетный менеджер загрузит около 300 мегабайт пакетов и дальше вы сможете использовать eclipse ничего не настраивая.

Выводы

Вот и все, теперь вы знаете как установить Eclipse Ubuntu 16.04. Если у вас остались вопросы, спрашивайте в комментариях!

источник

Блог Владимира ТюрюкОва

Рецепты решения проблем с компьютерами и программами

Как установить Eclipse на Linux?

Чтобы установить Eclipse на Linux нужно сделать следующее:

Зайти на официальный сайт Eclipse. Меня, например, интересовал Eclipse PHP Development Tool

Eclipse официальная страница загрузки

Eclipse PDT официальная страница загрузки

На официальном сайте нужно нажать кнопку Download.

Загрузится архив eclipse-xxxxx.tar.gz

Теперь необходимо распаковать архив в папку /opt и создать ярлык для исполняемого файла Eclipse

Как распаковать файлы дистрибутива (установочного комплекта от производителя) через консоль:

/ Загрузки / eclipse-php-luna-SR1a-linux-gtk-x86_64.tar.gz .
tar xzvf eclipse-php-luna-SR1a-linux-gtk-x86_64.tar.gz
cd eclipse
. / eclipse

здесь нужно учитывать, что версия Вашего дистрибутива могла изменится и имя файла не совпадет с моим. Исправьте имя файла на правильное перед вводом в консоли.

Второй вариант через графический интерфейс («установка мышкой»):

Нажмите ctrl+alt+T (или откройте терминал через меню)

в появившемся окне терминала наберите:

если у вас установлен файловый менеджер nemo он откроется от имени Суперпользователя (аналог Администратора в Windows).

Читайте также:  Установка плагина mode 2x2

Найдите папку загрузок в каталоге /home/имя_вашего_пользователя/Загрузки/

скопируйте загруженный файл Eclipse (его название должно быть похоже на это: eclipse-php-luna-SR1a-linux-gtk-x86_64.tar.gz) правой кнопкой мыши выбрав пункт Скопировать.

Вставьте этот файл (правой кнопкой мыши выбрав пункт Вставить) в папку /opt находящуюся прямо в начале файловой системы. Доступ Суперпользователя Вам нужен был именно для этой папки.

Нажмите правой кнопкой мыши на этом файле, выберите распаковать здесь.

Появится папка Eclipse.

Создайте ярлык для файла /opt/eclipse/eclipse в меню или на рабочем столе. Как создать ярлык в меню Gnome.

источник

Изучение C++ в Linux. Установка Eclipse CDT.

Сегодня я хотел написать статью о том как установить и настроить IDE в Linux (конкретно я работаю в Ubuntu 12.10, следовательно все примеры ориентированы для данной версии).

Установка Java

Для начала надо установить в системе Open Java SDK:

Через интерфейс:

Идем в «Центр приложений Ubuntu», вводим в поиск Java и ставим там OpenJDK Java 6 Runtime, потом ищем icedtea-6-plugin и устанавливаем его.

Через терминал:

Установка Eclipse

Следующий этап, это установка самого Eclipse и CDT для работы с C/C++. На данном шаге нам доступны несколько вариантов установки:

Из репозитория

Из репозитория удобно устанавливать потому что сама программа будет доступна в меню приложений.

Через интерфейс:

Через интерфейс: Идем в «Центр приложений Ubuntu», вводим в поиск Eclipse и устанавливаем его, потом вводим в поиск eclipse-cdt и так же ставим его.

Через терминал:

2. Скачать с сайта

Беря Eclipse с сайта, вы сразу получаете самую последнюю версию продукта. Для того что бы скачать Eclipse, идем по ссылке http://www.eclipse.org/downloads/ и качаем нужную нам версию продукта ( не забываем учитывать операционную систему и архитектуру). Скаченную версию с сайта устанавливать не надо, достаточно просто разархивировать и запустить бинарный фаил. Если у вас правильно установлена Java, то программа сразу запустится.

Тут тоже есть несколько вариантов установки.

1. Классическа версия: Качаем Eclipse Classic 4.2.2 ( версия может отличаться ), распаковываем и запускаем фаил «eclipse». Потом через инструмент установки новых компонентов ( Help → Install New Software), нужно установить из раздела Programming Languages пакеты C/C++ Development tools и C/C++ Development tools SDK ( в чем разница между ними мне пока не совсем понятна, возможно вы подскажите в комментариях ).

2. Скачать готовую сборку, Eclipse IDE for C/C++ Developers, в которую уже включено все необходимое для работы.

Выбор вкладки C/C++

Так как Eclipse рассчитан на большое количество языков программирования, то существует система вкладок, которая переключает интерфейсы программы. Переключение закладок находиться на верхней панели, справа, возле быстрого поиска.

Нажмите кнопку Open Perspective, и выберите C/C++.

Русификация

Для русификации продукта используйте статью, которую я писал ранее. Как русифицировать Eclipse

Настройка компиляции.

У меня был случай когда программа писала «binary not found». Для того что бы не было этой ошибки, проверьте установлен ли у вас компилятор:

Window → Preferences → C/C++ → New CDT Project Wizard → Makefile Project, и устанавливаем там галочку на против Elf Parser (если у вас Linux), PE Windows Parser (для Windows), Cygwin PE Parser (если у вас MAC).

Создаем тестовый проект.

File → New → C++ Project → Hello World C++ Project

Компилируем Ctrl+F11, если нет ни каких ошибок, значит мы настроили IDE для работы с C++ в операционной системе Linux.

источник

How to Install The Latest Eclipse Release in Ubuntu 14.04

This quick tutorial is going to show you how to install the latest release of Eclipse, while the Ubuntu repositories has an very old version.

Читайте также:  Установка инжекторного генератора 2108

So far, the latest is Eclipse Kepler (4.3.2). You can follow below steps to install it on Ubuntu 14.04 or other Ubuntu releases.

If you don’t have Java installed on your system. Click the link below to bring up Ubuntu Software Center and click install OpenJDK Java 7:

Or, install Oracle Java from this link.

You may check out your OS Type 32-bit or 64-bit by going to System Settings -> Details -> Overview

3. Extract Eclipse to /opt/ for global use

Press Ctrl+Alt+T on keyboard to open the terminal. When it opens, run the command below to extract Eclipse to /opt/:

You may replace “eclipse-*.tar.gz” (without quote) to the exact package name if the command does not work.

Don’t like Linux commands? You can do this by opening Nautilus file browser via root: Press Alt+F2 -> run gksudo nautilus .

Once done, you should see the eclipse folder under /opt/ directory.

4. Create a launcher shortcut for Eclipse

Press Ctrl+Alt+T, paste below command into the terminal and hit enter (install gksu from Software Center if below command does not work).

Above command will create and open the launcher file for eclipse with gedit text editor.

Paste below content into the opened file and save it.

[Desktop Entry]
Name=Eclipse 4
Type=Application
Exec=/opt/eclipse/eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Comment=Integrated Development Environment
NoDisplay=false
Categories=Development;IDE;
Name[en]=Eclipse

Finally open Eclipse from Unity Dash search results and enjoy!

Not clear enough? See the youtube video:

I’m a freelance blogger who started using Ubuntu 5+ years ago and wishes to share my experiences and some useful tips with Ubuntu beginners and lovers. Please notify me if you find any typo/grammar/language mistakes. English is not my native language. Contact me on Google Plus or email to ubuntuhandbook1@gmail.com

83 responses to How to Install The Latest Eclipse Release in Ubuntu 14.04

Thank you,
easy to follow and worked first time 🙂

Thanks bro. Thanks a lot for the steps. It works. 😀

Thanks a bunch for this. It was doing my head in! 🙂

I must admit that I’m having a problem– whenever I open eclipse, it shows the title screen and then the window goes white. To my knowledge I cannot find an error for it, it simply stops. Any ideas on why?

it seems the file you’ve downloaded is broken,try to do checksum matching

Thanks for this useful information Ji!

Wow ! That was quick and easiest way I have installed eclipse on linux. Thank you. Somehow software center has outdated version.

Thanks, very useful.
But for me the launcher location must to be .local/share/applications/eclipse.desktop

Thanks! Worked for me as well on 12.04!

when i run this cd /opt/ && sudo tar -zxvf

/Downloads/eclipse-*.tar.gz. it’s always show gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now ?
can you help?

The error output tells you that the package you downloaded is not complete. Remove it, and download again.

I have used your method but when I start eclipse it hangs after splash screen. I am using 64bit ubuntu 14.04 and eclipse 4.4.

$ java -version
java version “1.8.0_20”
Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b23, mixed mode)

Читайте также:  Установка и эксплуатация натяжных потолков

$ /opt/eclipse/eclipse -consoleLog -debug
Start VM: /usr/bin/java
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
-os linux
-ws gtk
-arch x86_64
-showsplash /opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140606-1215/splash.bmp
-launcher /opt/eclipse/eclipse
-name Eclipse
–launcher.library /opt/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326/eclipse_1605.so
-startup /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
–launcher.appendVmargs
-exitdata b48018
-product org.eclipse.epp.package.cpp.product
-consoleLog
-debug
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /opt/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
Install location:
file:/opt/eclipse/
Configuration file:
file:/opt/eclipse/configuration/config.ini loaded
Configuration location:
file:/home/som/.eclipse/org.eclipse.platform_4.4.0_1473617060_linux_gtk_x86_64/configuration/
Configuration file:
file:/home/som/.eclipse/org.eclipse.platform_4.4.0_1473617060_linux_gtk_x86_64/configuration/config.ini loaded
Loading timestamp file from:
file:/home/som/.eclipse/org.eclipse.platform_4.4.0_1473617060_linux_gtk_x86_64/configuration/ .baseConfigIniTimestamp
No timestamp file found
Timestamps found:
config.ini in the base: 1402558123000
remembered -1
Shared configuration location:
file:/opt/eclipse/configuration/
Framework located:
file:/opt/eclipse/plugins/org.eclipse.osgi_3.10.0.v20140606-1445.jar
Loading extension: reference:file:org.eclipse.osgi.compatibility.state_1.0.0.v20140403-1907.jar
eclipse.properties not found
Framework classpath:
file:/opt/eclipse/plugins/org.eclipse.osgi_3.10.0.v20140606-1445.jar
file:/opt/eclipse/plugins/
file:/opt/eclipse/plugins/org.eclipse.osgi.compatibility.state_1.0.0.v20140403-1907.jar
Splash location:
/opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140606-1215/splash.bmp
Debug options:
file:/home/som/.options not found
Time to load bundles: 8
Starting application: 2985

after that nothing happens. please help.

Hi! Congratulations for this post, it’s very useful. But I have a bit problem, when I try put “gksudo gedit /usr/share/applications/eclipse.desktop” in the box and I press Enter, my system do anything. I dont know it can be. Who know it?
Thanks you.

Very sorry for that, I found that many readers don’t know how to use the Alt+F2 box. I have updated the step 4, please run the command in a terminal window instead.

Hi ,could you explain me how i can remove eclipse after the installation with this guide?

Just remove the .desktop file and eclipse folder under /opt/. You need to open your file browser with root to do that.

I have used your provided method in Ubuntu 14.04 with JDK1.8.0_20 and Eclipse Luna for php development. I found following error when starting eclipse:

JVM terminated. Exit code=1
/usr/bin/java
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-vm /usr/bin/java
-jar /usr/local/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
-os linux
-ws gtk
-arch x86_64
-showsplash /usr/local/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp
-launcher /usr/local/eclipse/eclipse
-name Eclipse
–launcher.library /usr/local/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326/eclipse_1605.so
-startup /usr/local/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
–launcher.appendVmargs
-exitdata 67800f
-product org.eclipse.epp.package.php.product
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-vm /usr/bin/java
-jar /usr/local/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

Awesome job you did here mate!

Last time I installed Eclipse by myself and ended up with a somehow working software only after a couple hours of work, and this time i got it smoothly in a matter of minutes. Many thanks for that.

On my way to add ocaIDE and C stuff now… urg!

Just awesome! Thanks!
You may add how to install Eclipse for C/C++, run this command in terminal: sudo apt-get install build-essential
This will install the necessary C/C++ development libraries

I did all this, but whenever I try to run the program, it doesn’t do anything.

Make sure that eclipse downloaded is of correct bit. I also had the same issue. My ubuntu was 32 bit. But I downloaded 64 bit eclipse.

Check does it show and error in the console.

You can know your ubuntu type from

Make sure it matches with your eclipse.

Some things that I had to watch out for:
1. I have an office machine. It has an i3 processor, so I downloaded the 64 bit java and eclipse. When java -version command choked, I checked uname -m and System Settings -> Details -> Overview. The machine has been loaded with a 32-bit Ubuntu:-)
2. Since eclipse is in /opt/eclipse folder I needed to create a soft link to that in /usr/bin

The Eclipse executable launcher was unable to locate its
companion launcher jar.

Thanks! Very clear and useful instructions. Had me set up in no time!

источник