Меню Рубрики

Установка komodo ide ubuntu

Установка komodo ide ubuntu

Komodo это бесплатный текстовый редактор для динамических языков программирования, созданный компанией-разработчиком ActiveState. Это кроссплатформенный редактор подойдет почти любому программисту.

Komodo Edit унаследовал много свойств от коммерческой Komodo IDE, и поддерживает огромное количество языков программирования, например – PHP, Python, Ruby, JavaScript, Perl, Tcl, XML, HTML 5, CSS 3 и поддерживает все популярные операционные системы, такие как, GNU/Linux, Apple Mac OS, Microsoft Windows NT 5.0+.

  • Поддержка подсветки синтаксиса
  • Синтаксис на лету
  • Автозавершение скобок, кавычек и зарезервированных слов
  • Быстрый запуск и удалённая работа с файлами
  • Поддержка горячих клавиш
  • Инструментарий с интегрированной поддержкой командной оболочки, макросов и сниппетов
  • А также механизм расширений аналогичный Mozilla Firefox.

Установить Komodo в Ubuntu/Linux mint и другие

Официальный бинарник Linux содержит скрипт установки, так что вы можете легко установить Komodo Edit в Ubuntu с помощью следующих шагов

Перейдите на официальный сайт для скачивания архива установщика, выберите Linux (x86) для 32 – битной или Linux (x86_64) для 64 – битной Ubuntu.

После скачивания, откройте терминал(Ctrl+Alt+T), и перейдите в директорию загрузок

Перейдите в распакованную директорию

И запустите скрипт-установщик

Вам будет предложено ввести место для установки программного обеспечения. Для одноразового использования, рекомендуется оставить пустым и нажмите клавишу Enter.

Если вы хотите установить Komodo Edit в системную папку (например, /opt/Komodo-Edit) для глобального использования, запустите скрипт с помощью следующей команды вместо прошлой, и введите свой пароль

После установки, запустите редактор, либо с помощью ярлыка на рабочем столе, или из Unity Dash и наслаждайтесь!

А вам нравиться этот текстовый редактор? Поделитесь в комментариях.

источник

Установка komodo ide ubuntu

The following platforms are officially supported. Current Critical Updates, Windows Updates, and Service Packs must be installed (see http://windowsupdate.microsoft.com).

  • Windows 10
  • Windows 8 (but not supported as a Metro application)
  • Windows 7
  • Windows Server (2008 R2 or newer)
  • Perl Dev Kit: In order to build executable programs, ActiveX controls and Windows services in Perl, you must have ActiveState’s Perl Dev Kit version 3.1 or greater installed on your system.

Komodo IDE comes with a 21-day trial license. To install a permanent license:

  • Download the license installer from the My Account page.
  • Double-click the downloaded installer.

Newer versions of Komodo should not be installed in the same directory as older versions. For major release upgrades (e.g. x.0 to x+1.0) the installer will automatically put Komodo in a new directory.

For minor releases (e.g. x.0 to x.1) and patch-level releases (x.1.1 to x.1.2), use the auto-update system (Help|Check for Updates). The changes will be applied safely in the current install directory. If you need to update using an installer, completely uninstall the older version before installing the new one, or manually specify a different install directory during the installation process. Your Komodo preferences will be preserved as they are installed in a different directory.

  • If you intend to run the installation from a shared network drive, your system must have SYSTEM rights (or greater) to the directory from which the installation is run. Alternatively, run the installation from a local drive.

To install Komodo on Windows:

  1. Ensure you have the prerequisite hardware and software.
  2. Download the Komodo installer file.
  3. Double-click the installer file and follow the instructions.

When installation is complete, you will see an ActiveState Komodo icon on your desktop.

Komodo can also be installed from the command line. For example:

Komodo’s installer uses Windows Installer technology, which allows you to partially control the install from the command line. For example:

You can have the Komodo installer run with a reduced user interface. For example, the following will install silently and only open a dialog when the installation is complete.

The following will install with no dialog at all.

You can generate a log of the Komodo installation with the following command:

Читайте также:  Установка крыльев на велосипед stels 260

Command line options can be used to configure Komodo installation properties. The following will install Komodo to «E:\myapps\Komodo», instead of the default location:

Komodo is divided into a number of distinct features. In the «Customize Setup» dialog you can select which features to install. You can also do this on the command line with the ADDLOCAL property. For example, the following command will install just the core Komodo functionality (i.e. not the PyWin32 extensions or the documentation.

The current set of Komodo features are:

The hierarchy denotes dependencies (i.e. to install quicklaunch you must install the env .

The register option puts the Komodo location in the registry so ‘start komodo’ works, and adds bindings for .kpz and .kpf Komodo project files.

To start Komodo on Windows, use one of the following methods:

  • Double-click the desktop icon.
  • Select Start|Programs|ActiveState Komodo|Komodo.
  • Add the Komodo install directory to your PATH environment variable, then from the command line prompt, enter komodo .

To uninstall Komodo, select Start|Programs|ActiveState Komodo|Modify or Uninstall Komodo.

Alternatively, use the Add/Remove Programs menu (accessible from the Windows Control Panel).

  • Intel processor
  • 1 GB RAM
  • 250 MB hard disk space
  • 350 MB of temporary hard disk space during installation

Komodo IDE comes with a 21-day trial license. To install a permanent license:

  • Download the license installer from the My Account page.
  • Double-click the downloaded zip file to unpack it (this is done automatically if you are using Safari), and double-click the enclosed license installer.

Newer versions of Komodo should not be installed in the same directory as older versions.

For minor releases (e.g. x.0 to x.1) and patch-level releases (x.1.1 to x.1.2), use the auto-update system (Help|Check for Updates). The changes will be applied safely in the current install directory. If you need to update using an installer, completely uninstall the older version or rename the .app before installing the new one. Your Komodo preferences will be preserved as they are installed in a different directory.

  • Download the Komodo disk image ( Komodo-_ _-macosx.dmg ).
  • If the browser does not automatically mount the disk image and open the mounted folder in Finder, double-click the .dmg file to do so.
  • Open a new Finder window. Drag the Komodo icon from the mounted folder to the Applications folder.
  • If desired, drag the Komodo icon into the Dock.

Click the Komodo icon in the Dock or the Applications folder.

Drag the Komodo icon into the Trash.

  • 1GHz (or faster) x86 or x86_64 processor
  • 1 GB RAM
  • 250 MB hard disk space
  • 350 MB of temporary hard disk space during installation

Supported operating systems:

The following platforms are officially supported.

  • Red Hat Enterprise Linux 6 or later
  • CentOS 6.0 or later
  • Fedora Core 15 or later
  • OpenSUSE 12.1 or later
  • SuSE Linux Enterprise Desktop/Server 11.3 or later
  • Ubuntu 12.04 or later

Other operating systems:

Komodo may also run on other Linux based systems, or older versions of the above OS. You will need to verify this yourself, as Komodo is not tested on other platforms; and platform-specific bugs may exist there.

  • GTK+ 2.24 (or higher)
  • Glib 2.22 (or higher) — included in most standard Linux distributions.
  • Pango 1.14 (or higher)
  • X.Org 1.0 (or higher)
  • Libstdc++6
  • gdk-pixbuf (required on come platforms like Centos 6)
  • Gnome libraries (libgnome, libgnomeui)

Non-ASCII Input Requirements (IME):

To add Perl or Python to the PATH environment variable, do one of the following:

    Modify your PATH environment variable. For example, if you use the Bash shell, add the following line to your

. where points to the directory where you installed ActivePerl or ActivePython.

  • Create a symbolic link to the Perl or Python executable. For example, for ActivePerl, enter:
  • For ActivePython, enter:
Читайте также:  Установка радиатора кондиционера мазда 3

. where points to the directory where you installed ActivePerl or ActivePython.

Komodo IDE comes with a 21-day trial license. To install a permanent license:

  • Download the license installer from the My Account page.
  • Change the permissions on the downloaded file to allow execution (e.g. chmod +x Komodo- —
  • .executable )
  • Run the installer (e.g. ./Komodo_ _
  • .executable ).

Newer versions of Komodo should not be installed in the same directory as older versions. For major release upgrades (e.g. x.1 to x+1.0) the installer will automatically put Komodo in a new directory.

For minor releases (e.g. x.0 to x.1) and patch-level releases (x.1.1 to x.1.2), use the auto-update system (Help|Check for Updates). The changes will be applied safely in the current install directory. If you need to update using an installer, completely uninstall the older version before installing the new one, or manually specify a different install directory during the installation process. Your Komodo preferences will be preserved as they are installed in a different directory.

This version of Komodo allows non-root installation on Linux. Note, however, that the user who executes the license file will be the user who is licensed to use the software.

To install Komodo on Linux:

  1. Download the Komodo installer (.tar.gz file) into a convenient directory.
  2. Unpack the tarball:
  3. Change to the new directory:
  4. Run the install script («install.sh»):
  5. Answer the installer prompts:
  6. Specify where you want Komodo installed, or press ‘Enter’ to accept the default location ( /home/ /Komodo- -x.y ).The -I option can be used to specify the install directory. For example:

If multiple users are sharing the system and will be using the same installation, install Komodo in a location every user can access (e.g. /opt/Komodo-x.x/ or /usr/local/Komodo-x.x/ ).

  • Each Komodo user requires their own license key.
  • Do not install Komodo in a path that contains spaces or non-alphanumeric characters.
  • Be sure to install Komodo into its own directory (i.e. not directly in an existing directory containing shared files and directories such as /usr/local ).

Once the installer has finished, add Komodo to your PATH with one of the following:

  • Add Komodo/bin to your PATH directly:
  • Add a symlink to Komodo/bin/komodo from another directory in your PATH:

Note: Creating symlinks in system directories such as /usr/bin requires root access.

After completing the installation, you can delete the temporary directory where the Komodo tarball was unpacked.

To start Komodo on Linux enter komodo at the command line or create a shortcut on your desktop or in your toolbar using the full path to the komodo executable.

To uninstall Komodo on Linux:

  1. Delete the directory that Komodo created during installation.
  2. If you wish to delete your Komodo preferences, delete the

/.komodo directory. If you do not delete this directory, subsequent installations of Komodo will use the same preferences.

Note: You cannot relocate an existing Komodo installation to a new directory by simply moving it. You must uninstall Komodo from the existing location and reinstall it in the new location.

  • Debugging: If firewall software is installed on the system, it must be configured to allow Komodo to access the network during remote debugging.
  • Debugger Proxy: The optional Debugger Proxy ( pydbgpproxy ) requires Python to be installed on the target machine.
  • Node.js: You will need node v0.4 or greater to debug Node.js programs. You can get the latest version of Node for most platforms from nodejs.org. The komodo-debug package can be installed with npm for remote debugging.
  • Perl: Perl 5.6 or greater is required to debug Perl programs. Download the latest version of ActivePerl from the ActiveState website. Ensure that the directory location of the Perl interpreter (by default, C:\perl ) is included in your system’s PATH environment variable. On Windows, some features such as background syntax checking and remote debugging may require ActivePerl — there are known incompatibilities with Cygwin and msys perl.
  • Python: Python 2.4 or greater is required to debug Python programs. You can download the latest version of ActivePython from the ActiveState website. Ensure that the directory location of the Python interpreter (by default C:\Pythonxx (where «xx» is the Python version)) is included in your system’s PATH environment variable.
  • PHP: PHP 4.4 or greater is required to debug PHP programs. Download PHP from http://www.php.net/downloads.php. For complete instructions for configuring Komodo and PHP, see Configuring the PHP Debugger.
  • Tcl: Tcl 7.6 or greater is required to debug Tcl programs. Download the latest version of ActiveTcl from the ActiveState website.
  • Ruby: Ruby 1.8.4 or greater is required to debug Ruby programs. Download the latest version of Ruby from http://rubyinstaller.rubyforge.org/wiki/wiki.pl. Cygwin-based versions of Ruby are currently unsupported. Ruby 1.9.1 (and later) users will need to also install ruby-debug-base (e.g. gem install ruby-debug-base19 ) as a compatible version is not shipped with Komodo.

The debugging libraries for all languages are bundled with Komodo IDE, but they are also available for download from the Komodo Bits page.

  • CVS Source Control Integration: Requires CVS, which is available from http://www.nongnu.org/cvs/, or the latest stable version of CVSNT, which is available from http://www.cvsnt.org/wiki/.
  • CVS Source Control Integration using Putty (Windows): Requires Putty version 0.52 or greater.
  • Perforce Source Control Integration: Requires a connection to a Perforce server with version 99.1 or later.
  • Subversion Source Code Control Integration: Requires the svn command line client, available from http://subversion.tigris.org/. Komodo cannot use the TortoiseSVN client as its SVN executable.

© 2017 ActiveState Software Inc. All rights reserved. ActiveState®, Komodo®, ActivePerl®, ActivePython®, and ActiveTcl® are registered trademarks of ActiveState.
All other marks are property of their respective owners.

источник

Установка редактора Komodo в Xubuntu 14.04

Канадская компания ActiveState выпускающая кросс-платформенную среду разработки для всех основных языков и технологий, включая Python, PHP, Go, Perl, Tcl, Ruby, NodeJS, HTML, CSS, JavaScript, Django и т.д. В 2007 году компания разделила свой продукт Komodo на две ветви.

Komodo Edit — это кросс-платформенный текстовый редактор, который построен на движке Mozilla.

Komodo IDE — это коммерческая среда разработки, которая построена на Komodo Edit и имеет ряд дополнительных функций.

Сайт разработчика ActiveState — http://komodoide.com/

Таблица сравнения Komodo Edit и Komodo >

Особенность Komodo Edit Komodo IDE Multi-Language Editor ✓ ✓ Отслеживание изменений NEW ✓ ✓ Commando NEW ✓ ✓ Markdown Viewer NEW ✓ ✓ Kopy.io Интеграция NEW ✓ ✓ Документация NEW ✓ Run In-Line Tool NEW ✓ Менеджер пакетов интеграции NEW ✓ Docker Integration NEW ✓ Vagrant Integration NEW ✓ Shell Scope NEW ✓ Custom Workspaces NEW ✓ Отслеживание изменений с VCS NEW ✓ Auto-complete & Calltips ✓ ✓ Multiple Selections ✓ ✓ Toolbox ✓ ✓ Projects & Places Manager ✓ ✓ Skins & Icon Sets ✓ ✓ Minimap ✓ ✓ Code Refactoring ✓ Sections List ✓ Code Browser ✓ DOM Viewer ✓ Debugging ✓ Rx (Regular Expression) Toolkit ✓ HTTP инспектор ✓ Source Code Control Integration ✓ Unit Testing ✓ Code Profiling ✓ Database Explorer (MySQL, Oracle, etc.) ✓ Interactive Shells (Python, Perl, Ruby, Tcl) ✓ Perl Dev Kit/Tcl Dev Kit Integration ✓ Publishing ✓ Synchronize Multiple Workstations ✓ Real-Time Code Collaboration ✓

Для установки Komodo Edit выполним в Терминале следующие команды:

В результате установится последняя версия Komodo Edit, в нашем случае version 9.3.2, build 16460, platform linux-x86_64.

После загрузки и установки программы можно приступать к работе с Komodo Edit, открыв её из меню:

Меню → Разработка → Komodo Edit

источник

Добавить комментарий