Меню Рубрики

Установка kyocera 1040 в linux

KYOCERA FS-1040

Есть пользователи сабжа? Не было проблем с работой в GNU/Linux?

На официальном сайте для этого принтера присутствует CAPT драйвер, в общем, как повезёт, но пробуйте на 32 битной системе. А лучше купите принтер другого производителя или работающий не через capt драйвер, в таком случае 100% печать заработает.

Пользователи есть
Проблемы были
Худо бедно печатает

HP как правило проблемы не вызывает.

    А вообще, вот раньше всё было по другому — просто делаешь cat document.ps > /dev/lp0 и всё, никаких нафиг драйверов. Куда катится мир, блджад.

CAPT = как правило боль и ужас на на x86-системах. Включая amd64. Если от производителя нет 64-битных CAPT-драйверов под Linux — приготовься к длительной пляске с бубном — и не факт что заведется.

// негордый пользователь Canon i-SENSYS LBP5050

По советам вышеотписавшихся думаю о принтере по ссылке. Поправил ОП.

у меня с киосера на кальке проблем не было, причём у меня на работе в основном мфу за 25-30 шт, потому с принтером простым и подавно должно быть всё норм.

GDI Kyocera`ы адские говнища.

И вообще кёсеры с интерфейсом юсб смотреть очень не советую.

Хз кому из вас верить, но учитывая, что я только что вернулся из магазина, скоро скажу, кто оказался прав 😀

А почему ты не мог взять принтер с поддержкой PCL?

Подпишусь на тему. Отпишись, пожалуйста, потом разобрался ли с драйверами и если не сложно, даже попробуй мини-инструкцию по установке и настройке оставь, а то в руководствах не всегда все тонкости описаны. У меня сейчас HP LaserJet M1132 MFP, но вдруг у родителей HP LaserJet 1018 помрёт как-нибудь, а я на Kyocera посматриваю.

Заработал без танцев с бубном. Немного пофиксил найденный ppd для gentoo (см тут: https://github.com/jollheef/rastertokpsl-fs-1040), но там банальный s/lib/libexec/.

В остальном просто ставишь cups и install.sh из репа выше.

hp1020 — какой то ужас. печатает строго от положения звёзд. дело в драйвере. по молодости я бывало после танцев в бубном в лунную ночь заставлял это чудо рабоатть как часы. но молодость прошла, а принтер ещё не сломался. думаю вот иногда что надо бы прикупить другой.

а что такое plc и почему это важно?

На debian тоже заработал нормально. Сетевая печать отлично работает с lp -h host:631 file.pdf -d Kyocera_FS-1040.

Он везде так работает, хехе.

Более менее стандартизированный язык, можно продолжать пользоваться принтером несмотря на хотелки производителя. Вот jollheef свой принтер к роутеру не сможет присоединить. А HP LaserJet 6l заработает даже на десяточке и в последних линуксах, притом что список поддерживаемых ОС: OS/2, MS-DOS, Windows 95, Windows NT, Windows 3.11.

Вот jollheef свой принтер к роутеру не сможет присоединить.

Как ты на мипсе запустишь rastertokpsl?

Как ты на мипсе запустишь rastertokpsl?

Да, точно. К счастью, у меня есть домашний сервер.

Update: в отзывах на яндекса нашел:

Так что с роутерами проблем тоже не будет. Мне кажется, что ты преувеличиваешь PCL.

Написали драйвер по закрытым спецификациям?

Так что с роутерами проблем тоже не будет.

И как ты его запустишь без rastertokpsl?

Я откуда знаю? Нашел в комментах на яндекс маркете про d-link’овский принт сервер и еще один от ASUS, что подцепил.

Как-то оно работает. Если интересно — ищи авторов комментариев и спрашивай.

У меня дома стоит fs-1040. Драйвер — полный треш, требует 32-битные библиотеки, но кое-как печатает.

Большая часть проблем при печати по сети. Иногда проще скинуть pdf на комп, к которому оно подключено по usb, и запустить по ssh lp file.pdf , чем заставить это говно нормально напечатать через cups+ipp. По usb печатает нормально. Пробовал в разных комбинациях на debian, ubuntu и gentoo. Может дело и не в драйвере, а просто у меня кривые руки, и я не умею настраивать cups, но у старого струйника от hp таких проблем нет, хотя он работает в тех же условиях.

Никакой информации о тонере и ресурсе барабана оно в линуксе не показывает, только мигает двумя светодиодами на корпусе.

Переводные картинки для ЛУТ печатает нормально, а больше мне от него ничего не нужно, так что, с учетом его цены, я почти доволен.

Купи лучше киосеру с ethernet, или brother.

Купи лучше киосеру с ethernet, или brother.

С Etnerhet уже другие цены, да и смысла мне не было, если есть железка, которая работает 24/7.

Если нужен совет как настроить правильно — пиши, помогу.

Прочитал комментарии и понял, что у тебя оно уже работает. Тогда поздравляю с покупкой.

Я правильно понимаю, что печать по сети нормально заработала через LPD?

Я правильно понимаю, что печать по сети нормально заработала через LPD?

Настроил в cups на сервере принтер, открыл 631 порт и печатаю командой, которую писал выше (я терминалом в основном только пользуюсь, поэтому работает ли через гуй даже не скажу). Это не LPD, если я правильно понимаю, обычный HTTP.

Читайте также:  Установка ксенона в птф опель зафира

Печатать командой в терминале я тоже могу. А просто через меню браузера распечатать страницу по сети не получается — принтер уходит в астрал до перезагрузки по питанию, а у очереди печати на сервере начинается непроходимость из-за зависшего задания. Приходится сначала сохранять страницу в pdf, а потом уже печатать через lp file.pdf. что мне кажется немного унизительным занятием.

Принт-серверы (d-link) делают из не сетевого принтера сетевой. Драйвер на них (на те что я видел), ставить не надо. Там только пакеты из сети на USB пересылаются. А как пакет сформировать должен знать клиент.

Есть ещё роутер с usb, надо будет попробовать воткнуть в него принтер. Но там, наверное, тоже самое — архитектура проца не важна.

Мда, принт-сервер тут одни кавычки. Так что с нормальным не x86 принт-сервером кто-то обломится.

спасибо. а у тебя есть опыт общения с plc? в смысле хотелсь бы знать на скольки из поддерживаемых принтеров это заработало.

да, значит не я один такой счастливый. спасибо за инфу, хоть не так обидно.

В смысле? PCL работает везде где он есть, другое дело PPD файл надо подобрать, что не всегда получается. Зато раз и навсегда.

Open source is coming

Ebuild (безусловно, кривоват) на основе фильтра под OS X, полученного с помощью реверса:

Примечание: на hardened профиле (проверял на одной из машин) не работает.

Был пару лет назад. На Debian так и не завёлся, отдал отцу, он на оффтопе работает.

источник

MNorin.com

Блог про Linux, Bash и другие информационные технологии

Подключение принтера KYOCERA ECOSYS FS-1060DN в Linux

Установка драйверов для принтера Kyocera Ecosys FS-1060DN в Linux.

Описание принтера.

Общие характеристики
Тип печати черно-белая
Технология печати лазерная
Размещение настольный
Область применения малый офис, дом
Количество страниц в месяц 20000
Принтер
Максимальный формат A4
Автоматическая двусторонняя печать есть
Максимальное разрешение для ч/б печати 1200×1200 dpi
Скорость печати 25 стр/мин (ч/б А4)
Время разогрева 16 с
Время выхода первого отпечатка 7.50 c (ч/б)
Лотки
Подача бумаги 251 лист (стандартная), 251 лист (максимальная)
Вывод бумаги 150 листов (стандартный), 150 листов (максимальный)
Емкость лотка ручной подачи 1 лист
Расходные материалы
Плотность бумаги 60-220 г/м2
Печать на: карточках, этикетках, глянцевой бумаге, конвертах, матовой бумаге
Ресурс ч/б картриджа/тонера 3000 страниц, в комплекте картридж меньшей емкости
Количество картриджей 1
Тип картриджа/тонера ТК-1120
Память/Процессор
Объем памяти 32 Мб
Процессор ARM
Частота процессора 390 МГц
Интерфейсы
Интерфейсы Ethernet (RJ-45) 1
Интерфейсы USB 2.0 1
Шрифты и языки управления
Поддержка PostScript нет
Дополнительная информация
Поддержка ОС Windows, Mac OS, Linux
Потребляемая мощность (при работе) 346 Вт
Потребляемая мощность (в режиме ожидания) 6 Вт
Уровень шума при работе 49 дБ
Уровень шума в режиме ожидания 29 дБ
Габариты (ШхВхГ) 358x241x276 мм
Вес 6.7 кг

Установка драйверов в Linux.

Если вы приобрели принтер Kyocera FS-1060DN и при этом используете Linux, вам понадобится установить для него драйвера, поскольку они, скорее всего, не идут в комплекте с системой печати CUPS. Это файлы PPD, в которых содержится описание параметров принтера и его возможностей и фильтр для печати, программа, передающая принтеру информацию в понятном для него виде. Драйвера присутствуют на диске, входящем в комплект принтера, в виде файлов tar.gz. Однако это не самый удобный способ установки. Поэтому я собрал инсталлятор для Linux.

Вот как выглядит установка при его использовании:

Для установки потребуются права пользователя root, чтобы скопировать файлы в системные директории. Поэтому вам может понадобиться использовать команду «sudo».

В инсталлятор включены драйвера для следующих устройств:
— Kyocera FS-1020MFP
— Kyocera FS-1025MFP
— Kyocera FS-1040
— Kyocera FS-1060DN
— Kyocera FS-1120MFP
— Kyocera FS-1125MFP

После установки драйверов можно подключать принтер через CUPS. Как это сделать можно прочитать здесь.

Если есть какие-то вопросы и замечания, пишите. Контакты здесь.

P.S.: У инсталлятора есть Git-репозиторий, буду рад коммитам. Адрес: https://github.com/mnorin/kyocera-ppd-installer

Похожие посты:

Подключение принтера KYOCERA ECOSYS FS-1060DN в Linux : 58 комментариев

С 1025MFP всё получилось. Спасибо!

хочу понять что делать с этими тремя строчками, помогите.

Провозился с кеосерой 1020, с капса печатает с нужной мне программы нет, говорить печать остановлено, поставил ваш драйвер и БИНГО. Заработало! Спасибо!

не удалось получить фаил в соединении отказано

Добрый день. Поправил ссылку. Теперь файл доступен по протоколу https

Большое спасибо за ваш драйвер. До этого брал драйвер с официального сайта и не смог вылечить ошибку «FIlter failed». А ваш драйвер заработал.

Читайте также:  Установка задних подкрылков ланос

Всё сделал как выше написано, установилось всё. Спасибо!
Но когда зашёл в настройки принтера, далее найти принтер, нашёл драйвера автоматом. При пробной печати выдал ошибку.
Стоит Rosa Fresh KDE R8 версия KDE4 64-bit.
Пробовал конеш поставить рекомендуемые от другого принтера не помогло, качал с офф сайта и пробовал через ppd тоже не помогло.
Файл ошибки оставлю тут — https://cloud.mail.ru/public/BmDc/uNL6jiHY5
Надеюсь сможем решить проблему=)
Я просто новичок и не совсем понимаю как тут ещё всё устроено.

Спасибо за информацию. Это уже не первый случай с Росой.
К сожалению, до следующего месяца будет мало времени этим заняться, но я обязательно разберусь, в чем дело, и сделаю новую версию инсталлятора.
Ошибка заключается в том, что в Росе два простых способа узнать архитектуру системы (32-64 бита) не подходят, потому что кое-чего не хватает, в отличие от других дистрибутивов.
Надо будет посмотреть, как в этом дистрибутиве узнать архитектуру.
Можно еще добавиться в скайп (m.norin), помогу установить драйвера (точнее парсер, входящий в установочный пакет) в ручном режиме.

Спасибо за ответ. Как будет время обязательно Вам добавлюсь.
Я заметил что в этой Росе очень трудно с принтерами, еле как установил принтер HP Color LaserJet Pro MFP M117fw и Xerox Phaser 3125. Для НР он сам автоматом установил и не печатал, а утилита НР встроенная зависала и не работала, но всё же через неё получилось установить, а с выше принтером подошли драйвера от модели Phaser 2153.
А вот третий принтер не хочет работать!=)

Обновил инсталлер для драйверов, ссылка на новую версию в статье. Если есть возможность, проверьте, пожалуйста.

Добрый день. Manjaro x64. Kyocera 1060DN. При установке выдаёт.
Do you want to install [y/n]?: y
Installing…
cp: не удалось выполнить stat для ‘/tmp/kyosera_ppds/rastertokpsl_unknown’: Нет такого файла или каталога
Kyosera devices drivers are installed. You may use CUPS now.
Принтер висит со статусом. Простаивает — Rendering completed. Ничего не печатает.
На Убунту машинах всё работает.

Похоже, не удалось определить архитектуру. Можно посмотреть вывод команды arch и вывод uname -a?

arch не знает такую команду.
uname -a
Linux Toshiba 4.4.38-1-MANJARO #1 SMP PREEMPT Sat Dec 10 23:03:09 UTC 2016 x86_64 GNU/Linux

Спасибо. Постараюсь пофиксить завтра-послезавтра

Попробуйте, пожалуйста, новую версию (с гитхаба) и напишите, как оно

]$ sudo ./kyocera_ppds_installer_1.0.4.sh
./kyocera_ppds_installer_1.0.4.sh: строка 5: синтаксическая ошибка рядом с неожиданным маркером «newline»
./kyocera_ppds_installer_1.0.4.sh: строка 5: `’

]$ wget https://github.com/mnorin/kyocera-ppd-installer/blob/master/kyocera_ppds_installer_1.0.4.sh
—2016-12-24 03:01:05— https://github.com/mnorin/kyocera-ppd-installer/blob/master/kyocera_ppds_installer_1.0.4.sh
Распознаётся github.com (github.com)… 192.30.253.112, 192.30.253.113
Подключение к github.com (github.com)|192.30.253.112|:443… соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 200 OK
Длина: нет данных [text/html]
Сохранение в: «kyocera_ppds_installer_1.0.4.sh»

kyocera_ppds_instal [ ] 662,77K 816KB/s in 0,8s

2016-12-24 03:01:06 (816 KB/s) — «kyocera_ppds_installer_1.0.4.sh» сохранён [678679]

]$ chmod +x kyocera_ppds_installer_1.0.4.sh
[snak@Toshiba

]$ sudo ./kyocera_ppds_installer_1.0.4.sh
[sudo] пароль для snak:
./kyocera_ppds_installer_1.0.4.sh: строка 5: синтаксическая ошибка рядом с неожиданным маркером «newline»
./kyocera_ppds_installer_1.0.4.sh: строка 5: `’
[snak@Toshiba

]$ sudo chmod +x kyocera_ppds_installer_1.0.4.sh
[sudo] пароль для snak:
[snak@Toshiba

]$ sudo ./kyocera_ppds_installer_1.0.4.sh
./kyocera_ppds_installer_1.0.4.sh: строка 5: синтаксическая ошибка рядом с неожиданным маркером «newline»
./kyocera_ppds_installer_1.0.4.sh: строка 5: `’
Или так…

Подскажите как баг-репорты писать на гитхаб…. Arch и Manjaro победим…:)

В AURe к примеру адаптированного ppd. нету…

Хороший вопрос. Никогда не писал )
Можно сюда в комментариях писать. Интересная ошибка, я такой еще не видел. Сегодня поставлю Manjaro, посмотрю, в чем дело

В AURе есть пакет для принтеров kyocera, но 1060DN это региональная версия, и его там нет.:)

Кажется нашел.
https://github.com/mnorin/kyocera-ppd-installer/issues

Я это давно нашёл, как этим пользоваться чтоб всем удобно было?:)

Прямо там и создавать issues, выглядит достаточно удобно

Полюбилась мне Manjaro. Лёгенько плюс AUR. Здорово заработала, на нетбуке слабеньком, и на ноут поставил не молодой. Обнаружил более новые версие прог, которые через одно место работают на дебиан бэйс системах. Влюбился.:)))

Арч собирать ломовато, а Манжарик самое оно.:))

обнаружил почти сразу ядро для атомов, 4.4.21 не древнее. Нетбук 6-8 часов работает с ссд, вполне комфортно пользоваться на работе. Никаких перегруженых дженерик ядер, никаких обнов каждый день, всё что работало криво на дебиан бейс, работает ровно. Заметил что некоторые разработчики только в среде аур крутятся. Даже стим не надо с каждым обновлением шаманить сам работает. ХЗ что ещё желать. Чтоб 1060ДН заработал. Но это необходимость. В водянке на большом компе сдохла помпа, новая пока в техасе гдето трётся, к февралю приедет наверно. А работать надо.:)))

Мне, наверное, везло с Debian’ом. Бывало, конечно, приходилось под новое железо собирать свежее ядро из исходников, но со временем менял на пакетное. Нетбук под Jessie сейчас работает вполне прилично, правда, я систему потюнил немного, повыкидывал всё ненужное. Lenovo S10-2 на Атоме N270, кстати говоря, тоже на SSD ) Со свежей батарейкой тоже 6-8 часов. Правда, я на Дебиане с 2005 года, с версии 3.0, помню как обновлял на 3.1 «Sarge». И потом пару раз ставил 2.2 («Potato» вроде, последний раз ставил его на Пентиум 100 MHz с 16 Мб оперативки в 2011 году, когда более новые версии не вставали, потому что оперативки инсталлеру не хватало). Плюс для развития собирал как-то LFS. И Генту без хэндбука с третьего раза, давно правда. Опять же, в Дебиане всё можно при желании из сырцов собрать, в testing ветке софт посвежее. Manjaro я бы с удовольствием на настоящее железо поставил, но пока не на что.

Читайте также:  Установка передних пружин опель вектра

Максим, полный кат команд выкладывал, использовал get.

]$ wget https://github.com/mnorin/kyocera-ppd-installer/blob/master/kyocera_ppds_installer_1.0.4.sh
—2016-12-24 03:01:05— https://github.com/mnorin/kyocera-ppd-installer/blob/master/kyocera_ppds_installer_1.0.4.sh
Распознаётся github.com (github.com)… 192.30.253.112, 192.30.253.113
Подключение к github.com (github.com)|192.30.253.112|:443… соединение установлено.
HTTP-запрос отправлен. Ожидание ответа… 200 OK
Длина: нет данных [text/html]
Сохранение в: «kyocera_ppds_installer_1.0.4.sh»

kyocera_ppds_instal [ ] 662,77K 816KB/s in 0,8s

2016-12-24 03:01:06 (816 KB/s) — «kyocera_ppds_installer_1.0.4.sh» сохранён [678679]

]$ chmod +x kyocera_ppds_installer_1.0.4.sh
[snak@Toshiba

]$ sudo ./kyocera_ppds_installer_1.0.4.sh
[sudo] пароль для snak:
./kyocera_ppds_installer_1.0.4.sh: строка 5: синтаксическая ошибка рядом с неожиданным маркером «newline»
./kyocera_ppds_installer_1.0.4.sh: строка 5: `’
[snak@Toshiba

Тут проблема не в скачивании, а в выполнении. Но на всякий случай я запланировал какую-нибудь контрольную сумму уже встроить в скрипт.

я не эксперт, но в 5 строке скрипта, устаревший или слишком новый синтаксис. Сталкивался с таким при настройке conky.

Скачивается не то, что ожидается. Скачивается страничка, с которой должен скачиваться скрипт. Отсюда и ошибка.
Правильная ссылка выглядит так: https://raw.githubusercontent.com/mnorin/kyocera-ppd-installer/master/kyocera_ppds_installer_1.0.4.sh

Работает, спасибо большое. Поправь шапку… Пиши в почту если хочется пообщаться…

Дебиан слишком пропитан Деброй. Много действий. Мне манжарик дегче показался, плюс тру линукс вэй.Не пакетные обновы, тоже плюс как по мне. зайти с паролем один раз в пару недель лучше, чем каждый день и иногда не один. опера и манжарик с ядром под атомы, мне нравится. перепробывал все браузеры линукс остановился на опере. Ну кроме извратских консольных…

Точно поменял? У меня по старому.:)

Я ничего не менял, посмотри, что внутри. Файл должен быть порядка 172 килобайт, если размер 678679, то это не скрипт

всё заработало, для начинающих наверно первое с wget. не все шаристые бойцы чтоб с гитхаба чтото скачать, а скачав не поймут как ставится…

Добавил в статью строчку с wget и ссылкой на гитхаб для raw-файла

Что мне гоорит version в фигурных скбках работать не будет, мне то всё равно но начающие растроится могут.:)

Вот же дотошный человек )
Я уже придумал, как без версии обойтись. Сегодня, чуть попозже, сделаю

Я исключительно во благо человечества. Вдруг забыл, не доглядел. Я подскажу. Ничего такого.:)

Готово. Теперь есть просто ссылка, без версии, по которой будет скачиваться последняя версия скрипта.

Kyocera FS-1040 Не печатает несколько листов А5

Даже не знаю, чем вам помочь. Чтобы как-то решить проблему, надо хоть что-то. Кусочек лога CUPS, хоть какую-то информацию.
Плюс такого принтера у меня нет уже больше года, вряд ли смогу проверить печать на А5.

на Ubuntu 17
вылезает вот такое
Installer by Maxim Norin (https://mnorin.com, Mail: mnorin@mnorin.com).
Wrapper by tr0n (sorry, don’t have contact)

kyocera_ppds_installer.sh: 2261: [: unexpected operator
Do you want to install [y/n]?: kyocera_ppds_installer.sh: 2270: read: Illegal option -n

Спасибо за информацию. К сожалению, нет под рукой Ubuntu 17 в данный момент, поэтому быстро не проверю.

при этом на соседней машине на убунту 17 встало без вопросов

Подскажите на Linux of5 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u3 (2017-08-06) x86_64 GNU/Linux
не печатает kyosera FS-1060dn файл отправляю на печать в cups работа печати завершается, а сам он не печатает. Что можно сделать,

Принтер Куосера FS-1060 не выводит на печать хотя в cups печать завершена

А есть что-нибудь в логах CUPS?

Kyocera FS1060DN, Ubuntu 18.04 bionic, пока что Киоцеровское поделие работает.. Собственно, то же самое несложно делается руками, но скриптом удобнее.

Удалил из вашего комментария ссылку по причине того, что там требуется изменять файлы PPD. Не надо этого делать, любое обновление этих файлов на более новую версию и всё, принтер перестает печатать. Этот скрипт позволяет обновить файлы, скачав более свежую версию с сайта Kyocera, потому что используются оригинальные неизмененные файлы PPD.

Linux Mint 18.3 Sylvia принтер заработал, с официального сайта, находил, но печатать не хотел, тут о чудо всё работает, спасибо 🙂

Добавить комментарий Отменить ответ

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

источник

Добавить комментарий