Меню Рубрики

Установка периода динамического списка

Работа с динамическим списком в 1С 8.3 (8.2)

Наконец-то осуществилась мечта любого «семерошника». Как часто пользователи программы 7.7 просили сделать нормальный подбор номенклатуры. Чтобы и остатки можно было видеть, и цены, и установить фильтры. Приходилось придумывать разные хитрости, вплоть до написания внешних компонентов. В 1С 8.2 появились динамические списки. Предлагаю рассмотреть, что это такое и что они нам могут дать в 1С 8.3.

Создание формы выбора

За основу возьмем некую тестовую конфигурацию 1С:»Бухгалтерия предприятия 3.0″. Не будем сейчас делать подбор, просто в справочнике «Номенклатура» добавим еще одну форму выбора и сделаем ее временно основной:

При создании система по умолчанию добавит на форму табличное поле с типом «Динамический список».

Зайдем в его свойства и посмотрим, что там.

В первую очередь нас интересует флажок «Произвольный запрос». Он-то и откроет нам все преимущества динамического списка. У нас появится возможность написать собственный запрос, причем с параметрами. Устанавливаем флажок и нажимаем ссылку «Открыть»:

Если вы только начинаете программировать в 1С или просто хотите систематизировать свои знания — попробуйте Школу программирования 1С нашего друга Владимира Милькина. Пошаговые и понятные уроки даже для новичка с поддержкой учителя.
Попробуйте бесплатно по ссылке >>

Откроется окно с уже готовым кодом на языке запросов. Пока что там просто перечислены все поля справочника «Номенклатура».

Как видим, имеется кнопка вызова «Конструктора запроса» и флажок, который дает возможность динамически изменять содержимое списка. То есть когда другой пользователь меняет что-то в справочнике, в нашем списке это тоже изменится. Кроме того, имеется закладка «Настройки», но ее мы коснемся позже.

Собственный запрос в динамическом списке

Сначала создадим нужный нам запрос с остатками и ценами. Примерно так:

Закладка «Настройки»

И вот теперь самое вкусное! Переходим на закладку «Настройки». И сразу видим, что на первой вкладке мы можем делать любые отборы по любому полю в запросе:

Программная установка параметров запроса в динамическом списке 1С 8.3

Не забываем, что в запросе у нас присутствуют два параметра: «Период» и «Тип цен». Мы должны передать их в запрос, иначе будет ошибка.

Пропишем эти параметры в параметрах формы, а в модуле формы добавим следующие строки:

Значения параметров можно передать из объекта, откуда вызывается форма, либо другие, установленные по умолчанию.

Далее на форму с «Динамическим списком» можно добавить таблицу значений, куда будут при двойном клике передаваться строки с выбранным товаром и затем переноситься в документ.

Также на форму можно добавить флажок «Запрашивать количество».

В этом случае мы получаем уже простенький подбор товаров, однако с достаточно расширенными возможностями.

Если Вы начинаете изучать 1С программирование, рекомендуем наш бесплатный курс (не забудьте подписаться на YouTube — регулярно выходят новые видео):

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

источник

Особенности работы с объектом НастройкаПериода

В данном разделе рассмотрены особенности работы с объектом НастройкаПериода . Рассматриваются как работа объекта в табличных полях, отображающих «хронологические» динамические списки (свойство СтандартныйПериод), так и использование этого объекта для предоставления пользователю возможности, например, задавать интервал отчета, период за который нужно обработать данные и т.д.

Диалог Настройка периода

По умолчанию диалог Настройка периода имеет две закладки, которые позволяют выставлять промежуток времени в двух режимах, с использованием разных подходов. Диалог вызывается по команде «Установить интервал дат» в табличном поле или при вызове метода Редактировать() объекта НастройкаПериода .

Читайте также:  Установка и производство пластик

Закладка «Интервал» дает возможность установить отдельно начало и окончание временного промежутка, причем в привязке к рабочему периоду. Например, задавая интервал «с начала недели по конец месяца», пользователь задает промежуток времени, который определяется по рабочей дате. Т.е. задавая один и тот же интервал в разные дни, пользователь задает разные результирующие интервалы, в общем случае, разной протяженности. Этот подход удобен для динамических списков и отчетов имеющих оперативный характер (текущие продажи, текущие расчеты с контрагентами и т.п.).

Закладка «Период» дает возможность установить размер периода (месяц, квартал, год) и привязать его к той или иной точке времени, в том числе к рабочей дате. Например, Февраль 2003, 1-ый квартал 2004, текущий, т.е. соответствующий текущей дате, квартал. Этот подход более удобен для анализа финансовых показателей прошлого или текущего периода. Например, когда рабочая дата уже Апрель 2004 года, некоторое время еще важно анализировать и корректировать данные первого квартала 2004 года.

На обеих закладках есть возможность установить произвольный период — любые дату начала и окончания периода.

В связи с тем, что интервалы времени на разных закладках задаются по-разному, не всегда можно однозначно отразить период заданный на одной закладке в терминах другой закладки. Например, если в 31-го марта 2004 года задать на закладке «Интервал» промежуток «с начала года по конец месяца» (т.е. промежуток с 01.01.2004 по 31.03.2004), то в терминах закладки «Период» это можно воспринять как «текущий месяц с начала года», «текущий квартал», «текущая дата с начала квартала» и «текущая дата с начала года». С такой неоднозначностью может быть связано то, что простое переключение между закладками приведет к тому, что не изменившись по сути на текущий момент времени, период будет задан уже другим способом.

Использование в динамических списках

Ряд списков динамического просмотра данных содержат такие предопределенные поля, как Дата или Период. В табличных полях таких динамических списков, помимо обычной установки отбора через диалог «Отбор и сортировка», существует стандартная команда «Установить интервал дат». Эта команда дает возможность пользователю не только задать произвольный диапазон просмотра данных, но и задать стандартные интервалы в более удобных терминах — неделя, месяц, квартал, год, а также задать период в привязке к текущей дате.

Команда вызывает диалог «Настройка периода», который является средством интерактивного управления объектом НастройкаПериода. Этот диалог позволяет запомнить стандартную настойку периода, которая будет использоваться для списка при открытии формы. При работе с настройкой периода следует помнить, что установка отбора по дате через окно «Отбор и сортировка» и через окно «Настройка периода» выполняют действия над одним и тем же элементом отбора динамического списка. В некоторых случаях для отбора по дате может быть задан такой диапазон, который не может быть адекватно отражен диалогом Настройка периода.

Дело в том, что диалог «Настройка периода» подразумевает установку интервала в терминах дат без указания времени. Это более понятно и более удобно для пользователя, но приводит к некоторым особенностям. Например, дата начала интервала, заданная через настройку периода, соответствует началу заданного дня (нулевой секунде), а дата окончания интервала — концу заданного дня (время — 23:59:59). Это приводит к тому, что если за счет интерактивных действий пользователя или при использовании встроенного языка для элемента отбора по дате установлено ЗначениеС с ненулевым временем или ЗначениеПо с временем не равным 23:59:59, то диалог «Настройка периода» при открытии отразит эту ситуацию как невыбранную границу начала и конца интервала. Если при этом просто нажать Ok , будет выдано сообщение о невозможности установить такой интервал дат. Т.е. пользователю нужно будет определиться — устанавливать ли интервал на «целые» дни или отказаться от установки периода. Желание устанавливать отбор более точно, чем «днями», может возникнуть при интенсивном документообороте, когда нужно, например, проанализировать документы первой половины дня. В таком случае использование в динамических списках диалога «Отбор и сортировка» неизбежно.

Читайте также:  Установка кондиционера в узбекистане

Особенностью диалога «Настройка периода», появляющегося в динамических списках, является также то, что в диалоге имеется флажок «Использовать эту настройку периода при открытии». Установка этого флажка приводит к тому, что при нажатии OK настройка периода будет сохранена для текущего списка и использована при следующем открытии формы.

Использование в отчетах

Очень часто для получения отчета в бизнес-приложениях необходимо задавать интервал, за который формируется отчет. Для этого в соответствующей форме, в которой проводится настройка такого отчета, можно использовать объект НастройкаПериода. Как правило, при этом в форме размещают два поля ввода для даты начала и конца периода формирования отчета, а также копку по которой вызывается метод Редактировать() объекта НастройкаПериода.

При работе с этим объектом в случае, когда в элементах управления формы используются даты с квалификатором типа Дата (без времени), следует учитывать следующие особенности.

  1. Для того чтобы использовать третий параметр метода УстановитьПериод() (т.е. параметр «Предпочтительно использовать рабочий период»), необходимо запомнить в каком режиме пользователь настроил период — с привязкой к рабочему периоду (например, текущий месяц) или как абсолютный период (например, Апрель 2004). Привязка настройки к рабочему периоду происходит неявно, когда пользователь использует закладку Интервал, или явно — при установке флажка «Рабочий период» на закладке «Период». И в том и в другом случае привязка к рабочему периоду приводит к тому, что свойство ЗначениеПериода получает значение даты «начала отсчета» ( ‘ 00010101 ‘ ). Таким образом, для определения того, что использована привязка к рабочему периоду, достаточно сравнить ЗначениеПериода и ‘ 00010101 ‘ .
  2. При установке периода (метод УстановитьПериод()) необходимо приводить дату окончания к концу дня, но только в том случае, если в качестве даты окончания не задана дата начала отсчета. Эта особенность связана с тем, что дата начала отсчета ‘ 00010101 0:00:00 ‘ воспринимается объектом НастройкаПериода особым образом. Если ее задать в качестве даты окончания, это будет означать, что ограничение не установлено. Но дата ‘ 00010101 23:59:59 ‘ , как, впрочем, любая дата с ненулевым временем, уже не является «датой начала отсчета».
  3. Для сохранения заданной пользователем настройки периода между сеансами работы формы можно использовать способность объекта НастройкаПериода сохраняться и восстанавливаться (например, при помощи функций глобального контекста СохранитьЗначение, ВосстановитьЗначение).

Эти особенности проиллюстрированы в демонстрационной конфигурации «Примеры ИТС» на примере формы обработки ПримерИнтернетПочты (закладка формы «Отчет по контрагенту»).

В том случае, если в элементах управления формы используются даты с квалификатором «Дата + Время», пользователь должен быть подготовлен к тому, что он столкнется с поведением, похожим на описанное выше.

источник

Динамический список — как сделать отбор по дате ?

Есть список Чеков. Документов очень много. Как при открытии программно (!) установить отбор только за сегодня ?

Варианты фильтра — после открытия —

Пер = Новый СтандартныйПериод(НачалоДня(ТекущаяДата()),ТекущаяДата());
элементы.Список.Период = Пер;
Элементы.Список.Обновить();

Фильтруют уже отобранные данные. Т.е. сперва ты ждешь долго, потом видишь документы.

Как установить отбор в Списке до отбора данных ?

Даже ставлю дату руками, сохраняю значение — штатно. И потом ни в ПриСозданииНаСервере ни в ПриОткрытии не могу найти эти значения в отборах Списка

Сходу точно не скажу, но примерно следующий

(2) А это в какой момент делать ? Я не совсем понимаю , когда именно компоновщик выбирает значения из базы.
Самое ранее что происходит на форме списка — ПриСозданииНаСервере — сюда суваться ?

Сейчас попробую. Спасибо за наводку

Добавил , все проходит , но фактически журнал не фильтруется

&НаСервере
Процедура Расш1_ПриСозданииНаСервереПосле(Отказ, СтандартнаяОбработка)

Отбор = Список.КомпоновщикНастроек.Настройки.Отбор.Элементы;
УсловиеОтбора = Отбор.Добавить(Тип(«ЭлементОтбораКомпоновкиДанных»));
УсловиеОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(«Период»);
УсловиеОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
УсловиеОтбора.ПравоеЗначение = ТекущаяДата();
Список.КомпоновщикНастроек.ЗагрузитьНастройки(Список.КомпоновщикНастроек.Настройки);

(9) это бы обновляло форму только , но я вижу что нет ни отбора, и скорость открытия долгая — т.е. данные не фильтруются

(10)
нет не уверен ) Но и не ругалось . пробую с Датой

Вы уверены что в динамическом списке есть поле «Период»?

Отбор = Список.КомпоновщикНастроек.Настройки.Отбор.Элементы;
УсловиеОтбора = Отбор.Добавить(Тип(«ЭлементОтбораКомпоновкиДанных»));
УсловиеОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(«Дата»);
УсловиеОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
УсловиеОтбора.ПравоеЗначение = ТекущаяДата();
УсловиеОтбора.Использование = Истина;

(13) вот тут подробнее.
у меня
1С:Предприятие 8.3 (8.3.12.1685)
Розница, редакция 2.2 (2.2.11.16) ну тут не так важно

У меня расширением перекрыто ПриСозданииНаСервере

У вас такой же текст ?
В какую процедуру помещали ?
В списке настройки формы — Ваш отбор появился ?

Отбор = Список.КомпоновщикНастроек.Настройки.Отбор.Элементы;
УсловиеОтбора = Отбор.Добавить(Тип(«ЭлементОтбораКомпоновкиДанных»));
УсловиеОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(«Дата»);
УсловиеОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
УсловиеОтбора.ПравоеЗначение = ТекущаяДата();
УсловиеОтбора.Использование = Истина;

В форме списка Вашего расширения, посмотрите привязана ли эта функция к событию формы «ПриСозданииНаСервере»

(16) Пробуйте так. Должно работать

Отбор = Список.Отбор.Элементы;
УсловиеОтбора = Отбор.Добавить(Тип(«ЭлементОтбораКомпоновкиДанных»));
УсловиеОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(«Дата»);
УсловиеОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
УсловиеОтбора.ПравоеЗначение = ТекущаяДата();
УсловиеОтбора.Использование = Истина;

(18) пробую..
хотя так тоже пробовал вроде в процессе «проб и ошибок»

Список.Отбор.Элементы
Список.КомпоновщикНастроек.Настройки.Отбор.Элементы
Список.КомпоновщикНастроек.ПользовательскиеНастройки.Отбор.Элементы

а то нигде не могу найти принципиальную разницу

Попробовал. С указанием четко даты — не вышло — он точно по времени смотрит.
Поменял на
УсловиеОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно;
УсловиеОтбора.ПравоеЗначение = Дата(‘20190108’);

работает — отбирает быстрее, открывается быстрее. . НО ! 🙂
1. не видно интервала отбора — сверху формы
2. В настройках формы — нет этого фильтра.
И как бы ни ставил период , сбрасывал настройки — отбор остается
Т.е. он устанавливается и жестко и все

А если так —
Отбор = Список.КомпоновщикНастроек.Настройки.Отбор.Элементы;

то отбор не ставится вообще

Т.е. или тащатся не все данные, но тогда и отбора не видно и не отключить
Или тащатся все данные — но отбор не ставится

У меня сработал вот этот код:

лНовыйПериод = Новый СтандартныйПериод(НачалоДня(ТекущаяДата()), КонецДня(ТекущаяДата()+24*60*60));

При этом отбор показывается в панели быстрых отборов, как будто бы период задали руками. Решение почерпнуто по этой ссылке: http://1000and1c.blogspot.com/2016/11/1.html

У меня подобная проблема возникла в ЗиКГУ в Журналах документов, особенно кадровых.
Там важна дата события, а не дата создания документа, т.е. нужны отборы по полям типа «ДатаСобытия», «ДатаНачала», «ПериодРегистрации».

Можно, конешно, сделать в настройках два отбора по больше-меньше, но как-то фе.
Я кинул в реквизиты формы СтандартныйПериод и обрабатываю события

Диалог = Новый ДиалогРедактированияСтандартногоПериода;
Диалог.Период = Форма[Путь];
Диалог.Показать(Новый ОписаниеОповещения(«ВыбратьПериодЗавершение», ЭтотОбъект, Контекст));
КонецПроцедуры

ПолеСобытия = Новый ПолеКомпоновкиДанных(«ДатаСобытия»);

Если Отборы.Количество() = 0 Тогда
Отбор = Отборы.Добавить(Тип(«ЭлементОтбораКомпоновкиДанных»));
Отбор.ЛевоеЗначение = ПолеСобытия;
Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно;
Отбор.ПравоеЗначение = ДатаНачалаОтбора;
Отбор.Использование = Истина;

Отбор = Отборы.Добавить(Тип(«ЭлементОтбораКомпоновкиДанных»));
Отбор.ЛевоеЗначение = ПолеСобытия;
Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.МеньшеИлиРавно;
Отбор.ПравоеЗначение = ДатаОкончанияОтбора;
Отбор.Использование = Истина;
Иначе
Для каждого Отбор ИЗ Отборы Цикл
Если Отбор.ЛевоеЗначение = ПолеСобытия Тогда
Если Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно Тогда
Отбор.ПравоеЗначение = ДатаНачалаОтбора;
Отбор.Использование = Истина;
ИначеЕсли Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.МеньшеИлиРавно Тогда
Отбор.ПравоеЗначение = ДатаОкончанияОтбора;
Отбор.Использование = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецПроцедуры

Вообще-то, в ЗиКГУ в механизме Установить период есть возможность
выбрать Показать стандартные периоды и установить Сегодня

В Вашей ситуации, если нет потребности в последующем изменении периода, достаточно:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
.
УстановитьПараметрыОтбораПоПериоду(ПолеСобытия, ДатаНачалаОтбора, ДатаОкончанияОтбора);
//ГДЕ:
//ПолеСобытия = Новый ПолеКомпоновкиДанных(«Дата»);
//ДатаНачалаОтбора = НачалоДня(ОбщегоНазначения.ТекущаяДатаПользователя());
//ДатаОкончанияОтбора = КонецДня(ОбщегоНазначения.ТекущаяДатаПользователя());
//Ускорит процесс открытия формы — отключить стандартную установку периода
.
КонецПроцедуры

&НаСервере
Процедура УстановитьПараметрыОтбораПоПериоду(ПолеСобытия, ДатаНачалаОтбора, ДатаОкончанияОтбора)

Если Отборы.Количество() = 0 Тогда
Отбор = Отборы.Добавить(Тип(«ЭлементОтбораКомпоновкиДанных»));
Отбор.ЛевоеЗначение = ПолеСобытия;
Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно;
Отбор.ПравоеЗначение = ДатаНачалаОтбора;
Отбор.Использование = Истина;

Отбор = Отборы.Добавить(Тип(«ЭлементОтбораКомпоновкиДанных»));
Отбор.ЛевоеЗначение = ПолеСобытия;
Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.МеньшеИлиРавно;
Отбор.ПравоеЗначение = ДатаОкончанияОтбора;
Отбор.Использование = Истина;
Иначе
Для каждого Отбор ИЗ Отборы Цикл
Если Отбор.ЛевоеЗначение = ПолеСобытия Тогда
Если Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно Тогда
Отбор.ПравоеЗначение = ДатаНачалаОтбора;
ИначеЕсли Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.МеньшеИлиРавно Тогда
Отбор.ПравоеЗначение = ДатаОкончанияОтбора;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;

источник

Добавить комментарий

Adblock
detector